The Perfect Server Centos 5.2

Discussion in 'HOWTO-Related Questions' started by techmen8080, Nov 19, 2008.

  1. techmen8080

    techmen8080 New Member

    I get this message when trying to check quotas.

    quotacheck: Quota for users is enabled on mountpoint / so quotacheck might damage the file. Please turn quotas off or use -f to force checking.

    How do I correct the problem? Thank you in advance
     
  2. falko

    falko Super Moderator ISPConfig Developer

    It seems as if quota is already enabled.
    Try this:
    Code:
    quotaoff -avug
    quotacheck -avugm
    quotaon -avug
     
  3. techmen8080

    techmen8080 New Member

    quota file not found see below

    [email protected] ~]# quotaoff -avug
    quotaoff: Cannot find quota file on / [/dev/mapper/VolGroup00-LogVol00] to turn quotas on/off.

    Thanks so much for responding, techmen8080
     
  4. techmen8080

    techmen8080 New Member

    my fstab

    [[email protected]]# cat /etc/fstab
    /dev/VolGroup00/LogVol00 / ext3 defaults,usrquota,grpquota 1 1
    LABEL=/backup /backup ext3 defaults 1 2
    LABEL=/boot /boot ext3 defaults 1 2
    tmpfs /dev/shm tmpfs defaults 0 0
    devpts /dev/pts devpts gid=5,mode=620 0 0
    sysfs /sys sysfs defaults 0 0
    proc /proc proc defaults 0 0
    /dev/VolGroup00/LogVol01 swap swap defaults 0 0
     
  5. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ls -la /
    ?
     
  6. techmen8080

    techmen8080 New Member

    ls -la

    [[email protected] ~]# ls -la /
    total 170
    drwxr-xr-x 25 root root 4096 Nov 8 07:42 .
    drwxr-xr-x 25 root root 4096 Nov 8 07:42 ..
    -rw------- 1 root root 0 Oct 27 13:34 aquota.group
    -rw------- 1 root root 0 Oct 27 13:34 aquota.user
    -rw-r--r-- 1 root root 0 Nov 8 07:42 .autofsck
    -rw-r--r-- 1 root root 0 Oct 11 01:12 .autorelabel
    drwxr-xr-x 4 root root 4096 Oct 11 01:24 backup
    drwxr-xr-x 2 root root 4096 Nov 9 04:03 bin
    drwxr-xr-x 4 root root 1024 Oct 23 17:51 boot
    drwxr-xr-x 10 root root 13820 Nov 10 21:48 dev
    drwxr-xr-x 109 root root 12288 Nov 17 04:02 etc
    drwxr-xr-x 6 root root 4096 Nov 1 16:53 home
    drwxr-xr-x 14 root root 4096 Nov 9 04:03 lib
    drwx------ 2 root root 16384 Oct 10 18:40 lost+found
    drwxr-xr-x 2 root root 4096 Nov 8 07:43 media
    drwxr-xr-x 2 root root 0 Nov 8 07:43 misc
    drwxr-xr-x 2 root root 4096 Mar 29 2007 mnt
    drwxr-xr-x 2 root root 0 Nov 8 07:43 net
    drwxr-xr-x 2 root root 4096 Mar 29 2007 opt
    dr-xr-xr-x 259 root root 0 Nov 8 07:42 proc
    drwxr-x--- 21 root root 4096 Nov 14 08:29 root
    drwxr-xr-x 2 root root 12288 Nov 9 04:03 sbin
    drwxr-xr-x 2 root root 4096 Oct 10 18:41 selinux
    drwxr-xr-x 2 root root 4096 Mar 29 2007 srv
    drwxr-xr-x 11 root root 0 Nov 8 07:42 sys
    drwxrwxrwt 6 root root 4096 Nov 21 04:02 tmp
    drwxr-xr-x 14 root root 4096 Oct 10 18:45 usr
    drwxr-xr-x 27 root root 4096 Oct 24 12:13 var
    drwxr-xr-x 8 root root 4096 Oct 29 23:27 vz
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Can you run
    Code:
    rm -f aquota.group
    rm -f aquota.user
    and set up quota again?
     
  8. techmen8080

    techmen8080 New Member

    I ran the commands suggested then repeated the following.

    [email protected] ~]# touch /aquota.user /aquota.group
    [[email protected] ~]# chmod 600 /aquota.*
    [[email protected] ~]# mount -o remount /
    [[email protected] ~]# quotacheck -avugm
    quotacheck: Quota for users is enabled on mountpoint / so quotacheck might damage the file.
    Please turn quotas off or use -f to force checking.
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Can you delete both files again and then reboot?
     
  10. techmen8080

    techmen8080 New Member

    same result

    [[email protected] ~]# quotacheck -avugm
    quotacheck: Quota for users is enabled on mountpoint / so quotacheck might damage the file.
    Please turn quotas off or use -f to force checking.
     
  11. falko

    falko Super Moderator ISPConfig Developer

    I think I'd try
    Code:
    quotacheck -avugm[B][COLOR="Red"]f[/COLOR][/B]
    then.
     
  12. techmen8080

    techmen8080 New Member

    the result of quotacheck -avugmf

    [email protected] ~]# quotacheck -avugmf
    quotacheck: WARNING - Quotafile //aquota.user was probably truncated. Can't save quota settings...
    quotacheck: WARNING - Quotafile //aquota.group was probably truncated. Can't save quota settings...
    quotacheck: Scanning /dev/mapper/VolGroup00-LogVol00 [/] /
    done
    quotacheck: Checked 22860 directories and 238064 files
    quotacheck: Cannot find checked quota file for users on /dev/mapper/VolGroup00-LogVol00!
    quotacheck: Cannot find checked quota file for groups on /dev/mapper/VolGroup00-LogVol00!
     
  13. falko

    falko Super Moderator ISPConfig Developer

    Please try
    Code:
    rm -f aquota.group
    rm -f aquota.user
    touch /quota.user /quota.group
    chmod 600 /quota.*
    mount -o remount /
    quotacheck -avugm
     
  14. techmen8080

    techmen8080 New Member

    the mystery continues...

    [email protected] ~]# rm -f aquota.group
    [[email protected] ~]# rm -f aquota.user
    [[email protected] ~]# touch /quota.user /quota.group
    [[email protected] ~]# chmod 600 /quota.*
    [[email protected] ~]# mount -o remount /
    [[email protected] ~]# quotacheck -avugm
    quotacheck: Quota for users is enabled on mountpoint / so quotacheck might damage the file.
    Please turn quotas off or use -f to force checking.
     
  15. falko

    falko Super Moderator ISPConfig Developer

    Then I'm running out of ideas... :(
     
  16. uteliux

    uteliux Member

    Same problem, just after system install
     

Share This Page