The perfect desktop didn't work out, see the list

Discussion in 'HOWTO-Related Questions' started by One Way Dave, Apr 16, 2009.

  1. One Way Dave

    One Way Dave New Member

    I tried to follow the perfect Desktop howto. I used System>Admin>Add/Rem and checked off the list down to Scribus. It did the usual when adding new programs up until reboot. It does seem the programs installed ok, I opened a couple and they seem to work.

    Now I have no network devices (wired and wireless were both working before the download)

    When I open a terminal all I see is

    bash: /etc/bashrc: Permission denied
    bash-3.2$

    If I su it no longer accepts my root password.

    CAD no longer brings up the quit/reboot panel.

    When I open System>Admin>Network I get
    Errno17 File exists:'///etc/sysconfig
    Errno 20 Not a directory:'///etc/sysconfig/networking/'
    Errno 20 Not a Directory:'///etc/sysconfig/network-scripts/'
    Errno 20 Not a directory:'///etc/sysconfig/networking/devices/'
    Errno 20 Not a directory:'///etc/sysconfig/networking/profiles/'
    Errno 20 Not a directory:'///etc/sysconfig/networking/profiles//default'
    Error linking //etc/hosts to //etc/sysconfig/networking/profiles/default/hosts:Err 20 Not a Directory
    Error linking //etc/resolv.conf to //etc/sysconfig/networking/profiles//default/resolv.conf: Errno 20 Not a Directory

    Then Network Configuration opens with no devices present (used to have etho-0, etho-1, wlan-0)

    When I reboot I get a freeze, mouse clicks don't do anything (have to magic key to reboot).
    or
    When I reboot it works (except the network, terminal, su stuff).

    I sure could use some help in fixing this. My tech level is to reload Fedora 10 and start all over, but I'd rather not if there is a way to fix this.

    Dell D630
    Fedora-10 x86-64
    BC 4312 wireless with BC firmware installed
    compiz-fusion installed
    gnucash and OOO installed

    Thanks for any help, Dave
     
    Last edited: Apr 16, 2009
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What exactly did you do before you started getting errors? Was it something on the command line or in the GUI?
     
  3. One Way Dave

    One Way Dave New Member

    Hey Falko, thanks for the reply.

    I used the Fedora GUI package installer. I started at the top of the list and searched for each package and checked all that applied down to Scribus (just part of the list). Then clicked apply.

    On an attempt prior to this I had tried to do the same with all the packages on the list at one time. That did not work, but did not leave me with these goofs. ie I still had network, terminal etc.

    Dave
     
    Last edited: Apr 16, 2009
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    That's strange. What you can try is install the packages from the command line:
    Code:
    yum install package1 package2...
     
  5. One Way Dave

    One Way Dave New Member

    Ok here is todays events.

    Boot and login: OK, gnome looks and acts Ok except no network

    Terminal opens with:
    bash: //etc/bashrc: permission denied
    bash-3.2$

    I enter su and pw
    bash: /etc/bashrc: Invalid argument

    I enter cd ~root
    bash-3.2#

    I enter ls
    anaconda-ks.cfg

    It allows me to open anaconda-ks.cfg with gedit (I didn't change anything because I don't understand most of it)

    If I go Places>Computer>Filesystem
    the GUI shows the typical file structure I'm used to seeing except

    Desktop is empty (although my desktop shows Computer, my Home, Trash and 2 files I have on the DT

    Root is empty (I don';t remember root being empty)

    CAD works now

    I hope something here helps, thanks

    Dave
     
  6. One Way Dave

    One Way Dave New Member

    Not really, I have no network devices and can't install them through methods I know. At this time I'm going to reinstall fedora-10 and start over. Thanks, Dave
     
  7. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    But then you can't install the packages through the GUI either...
     
  8. One Way Dave

    One Way Dave New Member

    Sorry to be so confusing Falko. Everything was working fine before trying to install the packages for the perfect desktop. After trying to install, I lost all network connections both wireless and wired. I have reinstalled Fedora-10, and my broadcom firmware (tonight). I'm going to try to install the individual packages that you've suggested using the GUI package installer.
     

Share This Page