The logs are not refreshed

Discussion in 'Installation/Configuration' started by palcaraz, Aug 4, 2010.

  1. palcaraz

    palcaraz New Member

    First, thanks for the wonderful software that is ISPConfig.

    After a problem with the apache web server, the logs are not refreshed in ISPConfig 3.

    I have reviewed the logs and can not find errors, just shows me data from a previous date and was never updated

    Any idea what might be wrong?

    Thanks
    Pedro Alcaraz
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please ensure thet the cron daemon is running on your server and that you have nozt changed the mysql password of the ispconfig database user manually.
     
  3. palcaraz

    palcaraz New Member

    The cron daemon is running

    the ispconfig database user is untouched

    Thanks
    Pedro Alcaraz
     
  4. palcaraz

    palcaraz New Member

    Another fact, the job queue has several records when it has always been vacant

    Pedro Alcaraz
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The jobqueue table sys_datalog has to contain all records for at least 30 days for all servers and the status of every record has to be "pending" as this field is not used.
     
  6. palcaraz

    palcaraz New Member

    What else can be wrong to not refresh the logs?

    Thanks
    Pedro Alcaraz
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

  8. palcaraz

    palcaraz New Member

    Nothing happens.
    The field "updated" of table "server" has the value 2091.
    The value of the field "datalog_id" has grown and now has the 2095 value.

    I enabled debug mode, and ispconfig.log file has a size of 0 bytes.

    It's frustrating silence, can we do more?

    Thanks
    Pedro Alcaraz
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Run this command as root on the shell and post the output:

    /usr/local/ispconfig/server/server.sh
     
  10. palcaraz

    palcaraz New Member

    Nothing, silence
     
  11. palcaraz

    palcaraz New Member

    What output should have the command /usr/local/ispconfig/server/server.sh?

    Thanks
    Pedro Alcaraz
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    If it works, then no output should be shown.
     
  13. palcaraz

    palcaraz New Member

    It works, but logs are not updated.

    I do not know what is wrong. Is it possible to reinstall ISPConfig?

    Thanks
    Pedro Alcaraz
     
  14. palcaraz

    palcaraz New Member

    Sorry to insist, but I've noticed that are not created databases, and I can not change them.
    There is no error, but no changes are made.

    Thanks
    Pedro Alcaraz
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    any errors in the system log of the ispconfig monitor?
    any jobs in the jobqueue in the monitor?
     
  16. palcaraz

    palcaraz New Member

    In the jobqueue I have three pages of information, can mean
    something?
     
  17. palcaraz

    palcaraz New Member

    In the server.php script I see that you run the query

    $server_db_record = $app->db->queryOneRecord("SELECT * FROM server WHERE update = 1 AND server_id = ".$conf["server_id"]);

    that if I run in phpmyadmin

    SELECT * FROM server WHERE update=1 AND server_id = 1

    gives me an error

    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'update=1 AND server_id = 1
    LIMIT 0, 30' at line 1

    and it's because the field "update" is called "updated", I have wrong server.php script
    field name?

    Thanks
    Pedro Alcaraz
     
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    No, thats not the case. As you see in the sourcecode, this part is commented out and not used by ISPConfig.

    You can be assured that there is no bug in the code, otherwise you would find herre a few thousand posts already if there would be such an issue as ispconfig has about 15 - 20 thousand new installs per month.

    See here:

    http://www.howtoforge.com/forums/showthread.php?t=47674
     
    Last edited: Aug 25, 2010
  19. palcaraz

    palcaraz New Member

    SOLVED!

    The problem is mine, was improperly configured parameter extension_dir in the php.ini file for php-cli.
    So do not run mysql queries, nor was error in the log files, etc.

    Thank you very much for your patience Till
    Pedro Alcaraz
     
: log

Share This Page