The following changes are not populated

Discussion in 'General' started by thomasso, Jan 26, 2018.

  1. thomasso

    thomasso New Member


    I'm running ISPC 3 latest on ubuntu 16.04 for a few years.
    I dont know if it matters or not:
    Mysql was running physically on a separate server but mysql port was mapped with socat to the master server, so no dedicated DB server was configured on ISPC. Until today.
    I installed Ispconfig latest on the separate mysql server too (which currently holds the original dbispconfig database), mysql own database name is dbispconfig2 just to avoid confusion.

    I can see the slave server in the master ispconfig web interface, disabled DB on the master and enabled DB on the slave, but since then the changes are note populated any more.

    tried to run on both servers, no errors.

    any help would be appreciated
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Enable debug log mode on the master for the slave, then run on the slave and post the output that you get.
  3. thomasso

    thomasso New Member

    ~# /usr/local/ispconfig/server/
    Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock

    26.01.2018-20:05 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
    26.01.2018-20:05 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock

    # /usr/local/ispconfig/server/

    26.01.2018-20:05 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
  4. thomasso

    thomasso New Member

    after manually debugging server.php it turned out that for some reason the processed datalogs id was higher than the required, so I set "updated" in the slave DB to a lower number.
    the second error was that the sql user of the slave server could not update the server table in the master database, so I editetd it's privilege and now it's working
    (2nd error was maybe because I had this crazy mysql setup described in the OP)

    thanks anyway

Share This Page