The connection was interrupted!!

Discussion in 'General' started by Linocks, Dec 17, 2006.

  1. Linocks

    Linocks New Member

    What's wrong??

    I type https://mydomain.com:81 in my browser having updated to ISPConfig 2.2.9 and I get the below error

    The connection was interrupted

    The connection to www.mydomain.com:81 was interrupted while the page was loading.

    # The site could be temporarily unavailable or too busy. Try again in a few
    moments.

    # If you are unable to load any pages, check your computer's network
    connection.

    # If your computer or network is protected by a firewall or proxy, make sure
    that Firefox is permitted to access the Web.

    The completed installation of ISPConfig didn't report any problems : -

    Code:
    All prerequisites are fulfilled.
    Here we go...
    
    Connected successfully to db ispconfigdb
    Restarting some services...
     * Stopping Postfix Mail Transport Agent postfix                         [ ok ]
     * Starting Postfix Mail Transport Agent postfix                         [ ok ]
     * Stopping ftp server proftpd                                           [ ok ]
     * Starting ftp server proftpd                                                   - IPv6 getaddrinfo 'web.fiwiyaad.com' error: Name or service not known
                                                                             [ ok ]
    Shutting down ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not running
    ISPConfig system stopped!
    Starting ISPConfig system...
    Apache/1.3.37 mod_ssl/2.8.28 (Pass Phrase Dialog)
    Some of your private key files are encrypted for security reasons.
    In order to read them you have to provide us with the pass phrases.
    
    Server web.fiwiyaad.com:81 (RSA)
    Enter pass phrase:
    
    Ok: Pass Phrase Dialog successful.
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started
    ISPConfig system is now up and running!
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
    
    [email protected]:/tmp/install_ispconfig#
    Can anyone assist??
     
  2. edge

    edge Active Member Moderator

    did you open / forward port 81 on your firewall / router ?
     
  3. Linocks

    Linocks New Member

    No I didn't but I have now and it still doesn't work! I didn't have to open that port on my firewall/router and it worked previously. Besides, my server is in the DMZ of my LAN. :confused:
     
  4. edge

    edge Active Member Moderator

    I did a scan on your IP for port 80 and 81.
    Port 80 looks open. Port 81 does not!

    Is ISPconfig running?
    Try /etc/init.d/ispconfig_server start and see if you get an error.
     
  5. Linocks

    Linocks New Member

    The port is open - please try again.

    This is the result : -

    Code:
    [email protected]:~# /etc/init.d/ispconfig_server start
    -su: /etc/init.d/ispconfig_server: No such file or directory
    [email protected]:~#
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    What is the output of:

    ls /root/ispconfig
    ls /home/admispconfig
     
  7. Linocks

    Linocks New Member

    The connection was interrupted!

    Result : -

    Code:
    [email protected]:~# ls /root/ispconfig
    ls: /root/ispconfig: No such file or directory
    [email protected]:~#
    
    Result : -

    Code:
    [email protected]:~# ls /home/admispconfig
    ispconfig
    [email protected]:~#
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Looks like the update was aborted due to a error.

    Please run:

    mkdir /root/ispconfig

    and then unpack and install the update again. If you get a error during update, please post all error messages and not just the last one.
     
  9. Linocks

    Linocks New Member

    The connection was interrupted

    I did more than that Till. I actually reinstalled the Edgy-Eft then ISPConfig and got the error message as described at http://www.howtoforge.com/forums/showthread.php?t=9240 & did as suggested there too. The installation of the Edgy-Eft was successful.

    I then installed ISPConfig and that too worked. I got the ISPConfig interface in my web browser using the https: connection from my windows machine. By the time I had finished I was sooooo tired so I book-marked the page then I shutdown my windows machine (not the server) and went to bed. I went to a friend's house the next day and showed them the ISPConfig login, etc from their machine and then switched their machine off.

    Today I try and access the ISPConfig page via the bookmark and also by typing the address into my web browser and I get the same error message again. So I call my friend and ask him to access the page and he gets the same error message.

    Code:
        The connection was interrupted
    
        The connection to www.mydomain.com:81 was interrupted while the page was loading.
    
        # The site could be temporarily unavailable or too busy. Try again in a few
        moments.
    
        # If you are unable to load any pages, check your computer's network
        connection.
    
        # If your computer or network is protected by a firewall or proxy, make sure
        that Firefox is permitted to access the Web.
    
    I run the commands you asked me to run before & the output is a little different. See below : -

    Code:
    [email protected]:~# ls /root/ispconfig
    cronolog    httpd  openssl  scripts        sv
    cronosplit  isp    php      standard_cgis  uninstall
    [email protected]:~# ls /home/admispconfig
    ispconfig  mailstats
    [email protected]:~#
    
    Do you have any ideas?? :confused:
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run:

    /etc/init.d/ispconfig_server start

    Do you get any errors?
    Are you asked for a password?
     
  11. Linocks

    Linocks New Member

    The connection was interrupted



    Code:
    [email protected]:/# /etc/init.d/ispconfig_server start
    Starting ISPConfig system...
    Apache/1.3.37 mod_ssl/2.8.28 (Pass Phrase Dialog)
    Some of your private key files are encrypted for security reasons.
    In order to read them you have to provide us with the pass phrases.
    
    Server web.fiwiyaad.com:81 (RSA)
    Enter pass phrase:
    
    Ok: Pass Phrase Dialog successful.
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started
    FreshClam is already running!
    ISPConfig system is now up and running!
    [email protected]:/#
    No errors!! :D I was asked for a password! :( What caused the server to stop then? :confused:
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

  13. Linocks

    Linocks New Member

Share This Page