Textpattern/ISPConfig configuration problem

Discussion in 'General' started by bidevi, Sep 13, 2008.

  1. bidevi

    bidevi New Member


    1. .htaccess works with a password, so no problem here.
    2. The Textpattern directory contains a .htaccess file with these lines:

    RewriteEngine On
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^(.+) – [PT,L]

    RewriteRule ^(.*) index.php

    3. If we browse the file index.php now, we get an internal server error.

    Any suggestions would be most welcome. Thanx in advance.
  2. Hans

    Hans Moderator ISPConfig Developer

    Probably, there are no .htaccess files allowed in your web.
    To allow these files within your website, add the following lines within the Apache directive field of your website:

    <Directory "/var/www/web#/web">
    Options FollowSymLinks
    AllowOverride All

    Where web# is the webnumber as created by ISPConfig.
  3. bidevi

    bidevi New Member


    As I indicated in my first message here, .htaccess works for vhosts together with .htpasswd. In other words, .htaccess does work.

    The apache2.conf file on Debian Etch includes these lines:

    <Directory /var/www/*/web>
    Options +Includes -Indexes
    AllowOverride All
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    <Files ~ "^\.ht">
    Deny from all

    The configuration problem persists (as I haven't changed anything). Any more suggestions?
  4. Hans

    Hans Moderator ISPConfig Developer

    Ok then, Do you see any related error within /var/www/web#/log/error.log ?
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess the problem is this Äì. Please make sure that you do not use there umlauts or accented characters in the rewrite rule.
  6. bidevi

    bidevi New Member

    Actually, the Umlaut-characters are absent from the real script on the server. Somehow this only got garbled via the internet, maybe because I'm using Firefox on a Mac (it's the n-dash or m-dash copied from the real script that must have gotten distorted). So it already reads something like this (with a longer dash instead of the - :

    RewriteRule ^(.+) ‚ - [PT,L]

    In other words, this is not the solution to the problem.
  7. bidevi

    bidevi New Member

    The log says:

    [Sat Sep 13 10:11:29 2008] [error] [client] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.

    I do not know how to use "logLevel debug' to get a backtrace nor would I know how to interpret what it says.
  8. bidevi

    bidevi New Member


    Does nobody have a clue?
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    The error means that you must have entered there another redirect somewhere so that this results in a loop.

Share This Page