Test site??

Discussion in 'Installation/Configuration' started by timbo, Nov 19, 2005.

  1. timbo

    timbo New Member

    Hi.

    I want to know if its possible to create a working test site alongside an active domain. Can I create a directory such as /var/www/web1/web/testsite and be able to see the indexed page from www.example.com/testsite?

    I tried copying the original index.html files and error folder into the /var/www/web1/web/testsite folder I created, but when I pointed my browser there it said that I not permitted to access the requested URL (403 error - forbidden!) I checked all the directory permissions.

    Is there a way to enable this url so that I can test out CSS and other stuff before applying it to my site? :confused:

    Thanks!
    tb
     
  2. IntnsRed

    IntnsRed ISPConfig Developer

    If your web1 "user" is associated with the example.com domain, you'll be able to see it if you made that directory.

    Your 403 error is probably due to permissions on the subdirectory (and/or *.html file) when you created it.

    You'll want directory permissions of "775" or drwxrwxr-x. The key is the "other" permissions. The directory has to be flagged as "other" read/execute, and the various *.html files (or whatever files) as "other" read permissions.
    ________
    WEED MAPS
     
    Last edited: Mar 4, 2011
  3. timbo

    timbo New Member

    Okay,

    Here is the ls -l output of my /web/testsite directory.

    Code:
    user1@host:~/web/testsite$ ls -l
    total 8
    drwxrwxr-x  2 user1 web1 4096 2005-11-19 13:03 error
    -rwxrwxr--  1 user1 web1 1215 2005-11-19 12:57 index.html
    
    I think this means that the directories and files are set up correctly. I still get the 403 error. Is there something else I need to do?

    Thanks.
    tb
     
    Last edited: Nov 19, 2005
  4. IntnsRed

    IntnsRed ISPConfig Developer

    I'm assuming that your www.example.com domain is working fine -- working fine meaning that not only is Apache serving it up, but that it was ISPConfig-created and that it's fully functional.

    Anyway, that file and directory that you show have good permissions. But what are the permissions to the actual subdirectory of ~/web/testsite?
    ________
    TOYOTA SV-1
     
    Last edited: Mar 4, 2011
  5. timbo

    timbo New Member

    Yes, Apache is serving up the site, www.10thdimens10n.com, great. Did I mention that its a drupal site? However, the testsite is *.html only (for now.)

    Anyways, I'm trying to make this testsite so that I can start playing with a theme for it so that the content will fit right into it. Right now it's not much of anything.

    Here's the output of ./web ls -l:

    Code:
    user1@host:/var/www/web1/web# ls -l
    total 136
    -rw-r--r--  1 user1 web1 20255 2005-08-14 19:43 CHANGELOG.txt
    -rw-r--r--  1 user1 web1   749 2005-01-09 03:22 cron.php
    drwxr-xr-x  2 user1 web1  4096 2005-08-14 19:50 database
    drwxrwxr-x  2 user1 web1  4096 2005-11-16 16:36 error
    -rw-r--r--  1 user1 web1  8430 2003-06-11 15:50 favicon.ico
    drwxrwxr-x  2 user1 web1  4096 2005-11-16 23:14 files
    drwxr-xr-x  2 user1 web1  4096 2005-08-14 19:50 includes
    -rw-rw-r--  1 user1 web1  1215 2005-11-16 17:32 index.htmold
    -rw-r--r--  1 user1 web1   595 2004-08-21 01:42 index.php
    -rw-r--r--  1 user1 web1 10280 2005-04-23 00:07 INSTALL.txt
    -rw-r--r--  1 user1 web1 18019 2004-09-15 15:48 LICENSE.txt
    -rw-r--r--  1 user1 web1  1428 2004-09-15 15:53 MAINTAINERS.txt
    drwxr-xr-x  2 user1 web1  4096 2005-08-14 19:50 misc
    drwxr-xr-x  2 user1 web1  4096 2005-08-14 19:50 modules
    drwxr-xr-x  2 user1 web1  4096 2005-08-14 19:50 scripts
    drwxr-xr-x  3 user1 web1  4096 2005-08-14 19:50 sites
    [B]drwxrwxr--  3 user1 web1  4096 2005-11-19 13:03 testsite[/B]
    drwxr-xr-x  7 user1 web1  4096 2005-11-19 02:51 themes
    -rw-r--r--  1 user1 web1  8787 2005-04-06 14:04 update.php
    -rw-r--r--  1 user1 web1   347 2005-08-14 17:33 xmlrpc.php
    
    Again, should be accessible by others, right? Also, the error page being served up is an ISPConfig page. You can see it at www.10thdimens10n.com/testsite

    Thanks!
    tb
     
  6. falko

    falko Super Moderator

    Folders must always be executable by all! Your testsite folder is only executable by the owner and the group! Run
    Code:
    chmod 775 testsite
    , and the error should be gone.
     

Share This Page