Test Files

Discussion in 'General' started by falko, Aug 1, 2005.

  1. falko

    falko Super Moderator ISPConfig Developer

    Included in this zip are three files for testing Perl, PHP and SSI for a virtual host (please note: the file hello_world.pl must be uploaded to the cgi-bin directory, and you have to make it executable, e.g. chmod 755 hello_world.pl).
     

    Attached Files:

    • test.zip
      File size:
      826 bytes
      Views:
      3,256
  2. dranieri

    dranieri New Member

    Test Zip

    Thank you falko
     
  3. edge

    edge Active Member Moderator

    falko,

    As soon as I enable 'Suexec' in ISPconfig, I get a '500 error - Internal Server Error!' when I try to access the 'hello_world.pl' perl script.

    When 'Suexec' if off, there is no problem (I guess Suexec is working :p )

    Anyway.. This is how the dir looks like.
    Code:
    drwxr-xr-x   2 web22_support web22 4096 Mar 18 02:07 backup
    drwxrwxr-x   2 web22_support web22 4096 Mar 19 01:07 cgi-bin
    drwxr-xr-x   3 web22_support web22 4096 Mar 11 00:30 log
    drwxrwxrwx   2 web22_support web22 4096 Mar 10 23:28 phptmp
    drwxr-xr-x   2 web22_support web22 4096 Mar 10 23:28 ssl
    drwx------   2 web22_support web22 4096 Mar 17 11:53 tmp
    drwxr-xr-x   3 web22_support web22 4096 Mar 11 09:41 user
    drwxrwxr-x  16 web22_support web22 4096 Mar 16 16:23 web
    
    In the cgi-bin (hello_world.pl is chmod to 755)
    Code:
    -rwxrwxrwx  1 web22_support web22 379 Mar 19 01:07 hello_world.pl
    
    The other two files (info.php and ssi.shtml) work fine... That is... the ssi.shtml file is only showing
    Code:
    Dynamic HTML with Server Side Includes
    Date/Time on the server: 
    Name of this HTML file: 
    Installed server software: 
    Your web browser: 
    I have no clue why the perl script is not working in 'Suexec' mode.. (map and file is set to the correct user!)
     
    Last edited: Mar 19, 2006
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the full path to hello_world.pl?
    Which distribution do you use?
     
  5. edge

    edge Active Member Moderator

    full path to 'hello_world.pl' is: /home/www/web22/cgi-bin
    The distribution I'm using is: Fedora RC4

    Again.. With 'Suexec' off (in ISPconfig) the hello_world.pl runs fine.
     
  6. falko

    falko Super Moderator ISPConfig Developer

  7. edge

    edge Active Member Moderator

    Grrrr and guess what.. I knew that allready!! I have NO CLUE why I did not think about this!

    I guess there is no easy way of changin the home directory for websites in ISPconfig. (I allready have a lot of sites setup in the /home/www/ dir)

    Once againa.. Thank you falko
     
    Last edited: Mar 20, 2006
  8. falko

    falko Super Moderator ISPConfig Developer

    This would involve a lot of manual work (moving sites, changing paths in a lot of files, etc.), and it's likely that you break something...
     
  9. Blackknight

    Blackknight New Member

    You should be able to symlink /var/www to /home/www.
     
  10. alexillsley

    alexillsley ISPConfig Developer ISPConfig Developer

    :confused: It wont let me open the zip file, it says "The Compressed (zipped) Folder is invalid or coruppted." :confused:
     
  11. falko

    falko Super Moderator ISPConfig Developer

    Download and try again.
     
  12. alexillsley

    alexillsley ISPConfig Developer ISPConfig Developer

    i still get the error, i attached a screen shot of it.
     

    Attached Files:

  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Please try to save it on disk before you unpack it. The .zip file is downloading and unpacking fine for me.
     
  14. alexillsley

    alexillsley ISPConfig Developer ISPConfig Developer

    It still would not let me unpack it on my windows pc, so i downloaded it on my linux pc and unpacked it there:) thanks for making this:)
     
  15. falko

    falko Super Moderator ISPConfig Developer

    Maybe a problem with your zip software on Windows...
     
  16. vogelor

    vogelor ISPConfig Developer ISPConfig Developer

    problem with pearl

    all files are working except of the .pl file.
    1) the path is: /var/www/web14/cgi-bin/hello_world.pl
    2) suexec if on
    3) rights: 777 (to test)
    i got the error 404 not found.

    when i disable suexec and copy the file to /var/www/web14/web then it works?

    any idea????
     
  17. falko

    falko Super Moderator ISPConfig Developer

    What's the URL you used?
     
  18. mphayesuk

    mphayesuk New Member

    What I found is that you need to change the permissions to 777 and accept changes. Then change the permissions back to 655 and then it should work.

    Thanks
     
  19. vogelor

    vogelor ISPConfig Developer ISPConfig Developer

    www.muv.local/hello_word.pl (that means, YOU can't access the file from your pc)

    isn't that ok?
     
  20. vogelor

    vogelor ISPConfig Developer ISPConfig Developer

    OK - i try (tomorrow)
     

Share This Page