systemimager restore errors

Discussion in 'HOWTO-Related Questions' started by Randy, Oct 29, 2006.

  1. Randy

    Randy New Member

    Hi people,

    I've been testing the restore script from falko's website to restore an image. I have to test it this way because I will not be able to access my servers free since they will be installed in another city at a provider. System debian sarge 3.1 , sata discs.
    When I run the restore script I get the following errors:

    get_arch
    /tmp/my_loader2-3.master: line 41: logmsg: command not found
    DISKORDER=sd,cciss,ida,rd,hd
    /tmp/my_loader2-3.master: line 104: logmsg: command not found
    /tmp/my_loader2-3.master: line 120: logmsg: command not found
    /tmp/my_loader2-3.master: line 120: logmsg: command not found
    /tmp/my_loader2-3.master: line 132: logmsg: command not found

    /tmp/my_loader2-3.master: line 157: logmsg: command not found
    /tmp/my_loader2-3.master: line 158: logmsg: command not found
    /tmp/my_loader2-3.master: line 159: parted: command not found
    /tmp/my_loader2-3.master: line 163: logmsg: command not found
    /tmp/my_loader2-3.master: line 164: parted: command not found
    Killing off running processes.
    kill: usage: kill [-s sigspec | -n signum | -sigspec] [pid | job]... or kill -l[sigspec]
    udp-receiver: no process killed
    rsync: no process killed

    write_variables
    Debian GNU/Linux 3.1 \n \l

    Does antbody have some idea of how to solve this?
    Any help would be appreciated.

    Randy
     
  2. falko

    falko Super Moderator

    Some commands such as logmsg and parted are missing on your rescue system.

    What kind of rescue system is it? I have a server at Hetzner, and there I have a full Debian Sarge rescue system.
     
  3. Randy

    Randy New Member

    errors

    Hi Falko,

    For all clarity I should maybe give some insight on the hardware which I'm using.
    I have 2 dell PE860 servers with Sata hard drives (1x250Gb) 2Gb ram. To be able to install debian sarge on them I had to search the internet for an alternative kernel. I believe it's version 2.6.16 (sarge-custom-0801.iso ), which I'm using at the moment. The installs are all according to your howto's (if only you knew the impact you have..).
    In my further investigation of my problem I re-did the image and re-ran the addclients command. After that I burned a bootcd from systemimager to temporarily bypass your script, to be sure that it would at least work locally. (I also read that your script works for other people so that couldn't be the problem).
    Now the imaging process goes further without the afore mentioned messages, but when I restart the new system I get the GrubGrubGrubGrubGrubGrubGrub message filling up my screen. So the system hangs there.
    I don't know how to re-install grub using the expert-mode of the install cd which then uses busybox without the grub-install commands (not even ifconfig could I find). So I am stuck. Even if I could re-install grub locally, I think that systemimager should be able to restore grub when I do a remote imageing job. I have tried to intsall the testing version of systemimager (3.6.3) but that gave a lot of errors when I put back the image. So I'm really stuck here. I hope you have some good advice 4 me. I think that I have a problem because of the sata disks? Maybe you have also an advice on a good installer for sata systems.
    Highest regards,

    Randy:confused:
     
  4. falko

    falko Super Moderator

    You get problems if you take an image of an IDE hard disk (where partitions are named /dev/hda1,...) and wnat ot restore it to a system with an SATA disks (where partitions are named /dev/sda1,...). You must use the same type of hard disk on both systems (it's not necessary that they are from the same manufacturer or have the same size (but the HDD where you want to restore an image must not be smaller than the one of the original system)).
     
  5. Randy

    Randy New Member

    Hi,
    The image I want to restore is from the same server that I took it from. I'm now going to try with lilo instead of grub. Maybe it makes a diff. Which package provides the logmsg command? It seems to be missing on my system (as you already implied).
    Randy
     
  6. falko

    falko Super Moderator

    I couldn't find any Debian package that provides this command, and I don't know what it does (probably log something to a file... ;) ). I'd suggest you create a file /usr/bin/logmsg yourself:

    Code:
    #!/bin/sh
    exit 0
    and make it executable:
    Code:
    chmod 755 /usr/bin/logmsg
     

Share This Page