systemimage si_getimage error

Discussion in 'Installation/Configuration' started by cmpanel, Jul 13, 2005.

  1. cmpanel

    cmpanel New Member

    On RH9.0, golden client is running fine as below.

    root 11504 0.0 0.1 1708 612 ? S 12:15 0:00 rsync --daemon --config=/tmp/rsyncd.conf.11318

    But when I run below getting image I get below error, what am I missing here ? I installed the deps as instructed in the systemimager site.

    [root@server tmp]# si_getimage -golden-client xxx.xxx.xxx.83 -image cmpanel
    Can't locate XML/Simple.pm in @INC (@INC contains: /usr/lib/systemimager/perl /usr/lib/perl5/5.8.2/i386-linux-thread-multi /usr/lib/perl5/5.8.2 /usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.2 /usr/lib/perl5/vendor_perl .) at /usr/lib/systemimager/perl/SystemImager/Server.pm line 23.
    BEGIN failed--compilation aborted at /usr/lib/systemimager/perl/SystemImager/Server.pm line 23.
    Compilation failed in require at /usr/sbin/si_getimage line 45.
    BEGIN failed--compilation aborted at /usr/sbin/si_getimage line 45.
    [root@server tmp]#

    Would appreciate comments/advice
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    You have to install the Perl module XML::Simple.

    Open the Perl shell (please go sure to switch off your firewall before!):

    Code:
    perl -MCPAN -e shell
    If you open it for the first time, you have to answer a few questions, but you can mostly accept the default values. Then install the needed module:

    Code:
    install XML::Simple
    To leave the Perl shell, type q.

    Code:
    q
    That's it! :)
     

Share This Page