Systemimage on Ubuntu

Discussion in 'HOWTO-Related Questions' started by bt3wifu, Apr 18, 2008.

  1. bt3wifu

    bt3wifu New Member

    Hello,

    I found this article by falko very helpful

    http://www.howtoforge.com/howto_linux_systemimager

    But its for Debian users, I tried to make it work with Ubuntu but with no success. Here are the steps that I tried:

    1- I assumed that this can work on ubuntu so I followed the same steps, but when I tried to run si_prepareclient after answering with yes to first two questions the system aborts with error about couldn't write to a directory, I've created the directories, the error is gone but the program kept aborting.

    2- I uninstalled systemimager, and removed this line:

    deb http://download.systemimager.org/debian stable main

    3- Installed the package (I think from Ubuntu repo) because that's the only place for repos I have in source.lst.

    When I tried to run si_prepareclient, I found it does not exist.

    4- I tried downloaded the debs for both server and client from here:

    https://sourceforge.net/project/showfiles.php?group_id=259&package_id=278

    5- Tried to install the package using

    dpkg -i systemimager-server_4.0.2_all.deb

    but I got this error:

    Code:
    dpkg: regarding systemimager-server_4.0.2_all.deb containing systemimager-server:
     systemimager-boot-i386-standard conflicts with systemimager-server (>= 3.2.4)
      systemimager-server (version 4.0.2) is to be installed.
    dpkg: error processing systemimager-server_4.0.2_all.deb (--install):
     conflicting packages - not installing systemimager-server
    Errors were encountered while processing:
     systemimager-server_4.0.2_all.deb
    6- I looked for the deb version of 3.2.4 but couldn't find any, there are only rpm ones.

    7- The only option I have left was to compile from the source which I did, but that didn't work. (I will show the steps I took if that's needed).

    Here are some information that maybe needed:

    uname -m
    x86_64

    I really appreciate any help that will make system imager works for me. If you had some problems similar to what I have and you were able to conquer them please share your experience, if you have better steps to make it work please again share them.

    Thank you,

    P.S I forgot to mention I'm using Ubuntu 7.10
     
    Last edited: Apr 18, 2008
  2. bt3wifu

    bt3wifu New Member

    In case needed also:

    Code:
    #df -h
    
    Filesystem            Size  Used Avail Use% Mounted on
    /dev/mapper/vol1-vol1--root
                          xG  yG   zG   9% /
    varrun                xG  yK  zG   1% /var/run
    varlock               xG     0  zG   0% /var/lock
    procbususb             xM  yK   zM   1% /proc/bus/usb
    udev                   xM  yK   zM   1% /dev
    devshm                xG     0  zG   0% /dev/shm
    /dev/mapper/vol1-vol1--backup
                          xG  yK  zG   1% /backup
    /dev/sda1             xM   yM  zM  11% /boot
    /dev/mapper/vol1-vol1--home
                           xG  yM   zG   2% /home
    /dev/mapper/vol1-vol1--var
                          xG   yG  zG  22% /var
     
  3. falko

    falko Super Moderator ISPConfig Developer

    I think your SystemImager installation is messed up because of the many different installation methods you tried. It should work if you use the Ubuntu package right from the start, so it might be a good idea to set that system up again from scratch.
     

Share This Page