System user not created

Discussion in 'General' started by Alex1, Oct 12, 2009.

  1. Alex1

    Alex1 New Member

    When i create a new website it will create like root user (ispconfig 3.0.14 stable) i need to type manually

    adduser --home /var/www/clients/clientX/webXX/web --shell /bin/false --no-create-home --uid 50XX --gid 50XX --disabled-login --disabled-password webXX

    to add the system user

    when can i see to fix it?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. Alex1

    Alex1 New Member

    so i will delete all sites and i will recreate them

    debug log:
    Code:
    12.10.2009-15:03 - DEBUG - Processed datalog_id 161
    12.10.2009-15:03 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    12.10.2009-15:04 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    12.10.2009-15:04 - DEBUG - Found 1 changes, starting update process.
    12.10.2009-15:04 - DEBUG - Call function 'ssl' in plugin 'apache2_plugin' raised by event 'web_domain_insert'.
    12.10.2009-15:04 - DEBUG - Call function 'insert' in plugin 'apache2_plugin' raised by event 'web_domain_insert'.
    12.10.2009-15:04 - DEBUG - Creating Symlink: ln -s /var/log/ispconfig/httpd/test.org /home/clients/clients/client1/web16/log
    12.10.2009-15:04 - DEBUG - Creating Symlink: ln -s /home/clients/clients/client1/web16/ /var/www/test.org
    12.10.2009-15:04 - DEBUG - Creating Symlink: ln -s /home/clients/clients/client1/web16/ /var/www/clients/client1/test.org
    12.10.2009-15:04 - DEBUG - Adding the user: web16
    12.10.2009-15:04 - DEBUG - exec: chown -R web16:client1 /home/clients/clients/client1/web16
    12.10.2009-15:04 - DEBUG - exec: chown root:root /home/clients/clients/client1/web16
    12.10.2009-15:04 - DEBUG - exec: chmod 755 /home/clients/clients/client1/web16/
    12.10.2009-15:04 - DEBUG - exec: chmod 755 /home/clients/clients/client1/web16/\*
    12.10.2009-15:04 - DEBUG - exec: chown root:root /home/clients/clients/client1/web16/
    12.10.2009-15:04 - DEBUG - exec: chmod 777 /home/clients/clients/client1/web16/tmp
    12.10.2009-15:04 - DEBUG - exec: chown web16:client1 /home/clients/clients/client1/web16/log/error.log
    12.10.2009-15:04 - DEBUG - Disable SSL for: test.org
    12.10.2009-15:04 - DEBUG - Writing the vhost file: /etc/apache2/sites-available/test.org.vhost
    12.10.2009-15:04 - DEBUG - Creating the symlink: /etc/apache2/sites-enabled/test.org.vhost => /etc/apache2/sites-available/test.org.vhost
    12.10.2009-15:04 - DEBUG - Processed datalog_id 162
    12.10.2009-15:04 - DEBUG - Call function 'restartHttpd' in module 'web_module'.
    12.10.2009-15:04 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    
    so adduser doesn't work?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    grep sshusers /etc/group
     
  5. Alex1

    Alex1 New Member

    no lines returned
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run:

    groupadd sshusers

    on the shell. Then create a new website and check if the user for the new site gets created.
     
  7. evgtlt

    evgtlt New Member

    on my system (centos 5.4) also users not created.
    debug ispconfig.log:
    26.03.2010-18:26 - DEBUG - Found 1 changes, starting update process.
    26.03.2010-18:26 - DEBUG - Call function 'ssl' in plugin 'apache2_plugin' raised by event 'web_domain_insert'.
    26.03.2010-18:26 - DEBUG - Call function 'insert' in plugin 'apache2_plugin' raised by event 'web_domain_insert'.
    26.03.2010-18:26 - DEBUG - Creating Symlink: ln -s /var/log/ispconfig/httpd/cahe.ru /var/www/clients/client7/web8/log
    26.03.2010-18:26 - DEBUG - Creating Symlink: ln -s /var/www/clients/client7/web8/ /var/www/name.com
    26.03.2010-18:26 - DEBUG - Creating Symlink: ln -s /var/www/clients/client7/web8/ /var/www/clients/client7/name.com
    26.03.2010-18:26 - DEBUG - Adding the group: client7
    26.03.2010-18:26 - DEBUG - Adding the user: web8
    26.03.2010-18:26 - DEBUG - exec: chown -R web8:client7 /var/www/clients/client7/web8
    26.03.2010-18:26 - DEBUG - exec: chown web8:client7 /var/www/clients/client7/web8
    26.03.2010-18:26 - DEBUG - exec: chmod 751 /var/www/clients/client7/web8/
    26.03.2010-18:26 - DEBUG - exec: chmod 751 /var/www/clients/client7/web8/*
    26.03.2010-18:26 - DEBUG - exec: chmod 710 /var/www/clients/client7/web8/web
    26.03.2010-18:26 - DEBUG - exec: chmod 777 /var/www/clients/client7/web8/tmp
    26.03.2010-18:26 - DEBUG - exec: usermod --groups sshusers web8
    26.03.2010-18:26 - DEBUG - exec: chown web8:client7 /var/www/clients/client7/web8
    26.03.2010-18:26 - DEBUG - exec: chown web8:client7 /var/www/clients/client7/web8/log/error.log

    typing manually:
    usermod --groups sshusers web8
    usermod: user web8 does not exist

    grep web /etc/passwd
    webalizer:x:67:67:Webalizer:/var/www/usage:/sbin/nologin
    [[email protected]]#
    [[email protected]]# grep sshusers /etc/group
    sshusers:x:5008:
    [[email protected]]#

    where is my error? :)
     

Share This Page