System update vhost problems

Discussion in 'Installation/Configuration' started by toux, Dec 7, 2010.

  1. toux

    toux New Member

    Hello,

    Two days ago I update Debian lenny by apt-get update and now my websites not load, when I restart apache show,

    ... waiting [Tue Dec 07 08:31:36 2010] [warn] NameVirtualHost my.ip.:443 has no VirtualHosts

    I enter on etc/apache2/sites-enabled and sites-available and I can see the vhosts files of the domains.

    Please help

    Thank you
     
  2. toux

    toux New Member

    Up!

    some idea for help please?
     
  3. falko

    falko Super Moderator

    Any errors in Apache's error log?
     
  4. toux

    toux New Member

    Hi Falko

    Thank you for your reply

    In the log of the domain I see so much like this:
    [Wed Dec 08 19:44:17 2010] [error] [client 128.238.49.17] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /w00tw00t.at.ISC.SANS.test0:)
    [Wed Dec 08 19:46:09 2010] [error] [client 128.238.49.17] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /w00tw00t.at.ISC.SANS.test0:)

    In the apache log this I can see:

    [Thu Dec 09 04:27:59 2010] [notice] caught SIGTERM, shutting down
    [Thu Dec 09 04:27:59 2010] [notice] mod_fcgid: process /var/www/mydomain.com/web/categorias.php(1794) exit(shutting down), terminated by calling exit(), return code: 0
    [Thu Dec 09 04:27:59 2010] [notice] mod_fcgid: process /var/www/mydomain2.com/web/index.php(22235) exit(shutting down), terminated by calling exit(), return code: 0
    [Thu Dec 09 04:28:00 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Thu Dec 09 04:28:00 2010] [notice] Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny9 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operations
    [Thu Dec 09 05:37:06 2010] [notice] mod_fcgid: call /var/www/mydomain.com/web/categorias.php with wrapper /var/www/php-fcgi-scripts/web3/.php-fcgi-starter

    Thank you

    David
     
  5. toux

    toux New Member

    Please somebody has some idea what can be the problem?

    Thanks
     
  6. falko

    falko Super Moderator

    Can you post the output of
    Code:
    ls -la /var/www/mydomain2.com/web/
    ?
     
  7. toux

    toux New Member

    server1:~# ls -la /var/www/mydomain2.com/web/
    total 740784
    drwxr-xr-x 26 web3 client0 4096 oct 8 03:53 .
    drwxr-xr-x 6 root root 4096 dic 9 04:05 ..
    drwxr-xr-x 4 web3 client0 4096 jun 8 2010 admin
    -rw-r--r-- 1 web3 client0 1918 jun 8 2010 autocomplete.php
    -rw-r--r-- 1 web3 client0 809 jun 8 2010 background.gif
    -rw-r--r-- 1 web3 client0 4494 jun 8 2010 browse.php
    drwxrwxrwx 2 web3 client0 4096 oct 31 20:31 cache
    -rw-r--r-- 1 web3 client0 2163 jun 8 2010 categorias.php
    drwxr-xr-x 2 web3 client0 4096 jul 19 2009 cgi-bin
    -rw-r--r-- 1 web3 client0 193 jun 8 2010 conectar.php
    -rw-r--r-- 1 web3 client0 2284 jun 8 2010 contact.php
    drwxr-xr-x 3 web3 client0 4096 jun 11 11:24 admin2

    Here is a part of the code I have so so much files on web folder

    Thank you Falko for your help

    Regards
     
  8. falko

    falko Super Moderator

    Hm, looks ok. What's in/var/www/php-fcgi-scripts/web3/.php-fcgi-starter?
     
  9. toux

    toux New Member

    Hi Falko thank you another time

    In this file i can see the next:

    #!/bin/sh
    PHPRC="/etc/php5/cgi/"
    export PHPRC
    PHP_DOCUMENT_ROOT="/var/www/clients/client0/web3"
    export PHP_DOCUMENT_ROOT
    PHP_FCGI_CHILDREN=8
    export PHP_FCGI_CHILDREN
    PHP_FCGI_MAX_REQUESTS=5000
    export PHP_FCGI_MAX_REQUESTS
    exec /usr/bin/php-cgi $1

    Regards
     
  10. falko

    falko Super Moderator

    Does
    Code:
    /var/www/php-fcgi-scripts/web3/.php-fcgi-starter /var/www/mydomain2.com/web/index.php
    or
    Code:
    /var/www/php-fcgi-scripts/web3/.php-fcgi-starter /var/www/mydomain.com/web/categorias.php
    show any errors?
     
  11. toux

    toux New Member

    Hi Falko,

    No show error, I can see the code of the index.php of the script. I don't know what is happend here, this comes from a apt-get update. and From this not run, I have debian Lenny installed.

    Regards and thanks for your help

    Toux
     

Share This Page