System Requirements Question

Discussion in 'General' started by dayjahone, Jan 4, 2009.

  1. dayjahone

    dayjahone Member

    I am trying to set something up that has the following requirements:

    Code:
    FFMPEG Latest Version with libmp3 and (latest faac and faad2 codecs for Mp4 Conversion)
    for low category conversion only
     Mplayer
    Mencoder
    Flvtool2 (optional)
    CLI enabled Hosting
    Exec function enabled for background process "exec()"
    mod_rewrite enabled for SEO links
    Are any of these installed with Ubuntu by default? I have a system I just setup following the perfect setup for Hardy Heron.

    1) Will any of this conflict with ISPConfig and be usable by sites setup through ISPConfig?

    2) Anyone know the packages for ubuntu for these if they're not installed by default?

    Sorry for all the questions.
     
    Last edited: Jan 4, 2009
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This should not conflict with ISPConfig.
     
  3. dayjahone

    dayjahone Member

    So, I think I've done the rest right, but I don't know about these two requirements:

    Code:
    GD Library with TTF Support
    Must be able to run PHP from the command line (CLI) with exec()
    Allowed execution of background processes with exec("binary > /dev/null &")
    I don't suppose anyone's used Clip Bucket?

    Thanks.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    This should be all there if you installed your server as described in the perfect setup.
     
  5. Leszek

    Leszek New Member

    I've used ClipShare.
    GD should be on by default. Check if it's listed when You run phpinfo();
    Be sure not to disable exec() in php.ini
    The rest should be ok by default.
    There is a possibility that there will be no sound if You're using binary only software.
     

Share This Page