System Monitoring error?

Discussion in 'General' started by AceP1983, Jan 14, 2010.

  1. AceP1983

    AceP1983 New Member

    I just started to receive this error when i try to view monitoring on my server:

    Warning: Invalid argument supplied for foreach() in /usr/local/ispconfig/interface/web/monitor/show_sys_state.php on line 139

    I am running the latest release and haven't made any changes since i updated back when 3.0.1.6 was first released. This is preventing all monitoring functions from working. Thanks for any help.
     
  2. till

    till Super Moderator

    Looks as if there is no monitoring data available. Please check if cron is running on your server (try: "/etc/init.d/cron restart" or similar script name) and then wit 15 minutes and check the ispconfig monitor again.
     
  3. AceP1983

    AceP1983 New Member

    I tried restarting cron even though i was pretty sure it wasn't cron because other cron jobs that i have set are still working fine. Still no luck. Any other suggestions?
     
    Last edited: Jan 14, 2010
  4. till

    till Super Moderator

    Any errors in the system log in the ispconfig monitor? Any pending jobs in the jobqueue?
     
  5. AceP1983

    AceP1983 New Member

    till, both the system-log and job queue are completely empty. This is really boggling my mind :confused:
     
  6. UOgod619

    UOgod619 New Member

    I'm having this issue as well

    I used the following guide to create my server:

    http://www.howtoforge.com/perfect-server-ubuntu-9.10-ispconfig-3

    Other than that I have only used the DNS tab to create my DNS server via MyDNS and I now have the same issue. The system monitoring worked perfectly for the first day and now it will not work even directly after reboot.
     
  7. Miglandz

    Miglandz New Member

    I have to this problem when I upgrade mysql on my ubuntu server :(
     
  8. till

    till Super Moderator

    Try to resatrt mydns and tchen check with

    netstat -tap

    if mydns is running.
     
  9. AceP1983

    AceP1983 New Member

    Tried restarting mydns, checked netstat and verified that it was running but still no luck. :confused:
     
  10. till

    till Super Moderator

    Is this a vserver?
     
  11. alexxo

    alexxo New Member

    Solved: Repair database table

    Looking at line 139 of /usr/local/ispconfig/interface/web/monitor/show_sys_state.php I saw there is a reference to the monitor_data table.
    The table was crashed and the solution was to repair it.

    $mysql -h localhost -u root -p
    mysql> check table monitor_data; => Table './dbispconfig/monitor_data' is marked as crashed and should be repaired
    mysql>repair table monitor_data;

    That did the trick for me.
     

Share This Page