synchronization between master and slave server

Discussion in 'ISPConfig 3 Priority Support' started by xanela, Sep 25, 2017.

  1. xanela

    xanela Member HowtoForge Supporter

    Hello, I have two debian wheezy servers, which are installed in clusters (primary and secondary). I encounter the problem that my servers have lost synchrony. There are things on the main server that are not on the slave server. What actions do I have to take to resolve this problem? Thank you very much
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which service are you talking about? Missing files, missing databases, missing websites, missing data in a website database?
     
  3. xanela

    xanela Member HowtoForge Supporter

    The problem has been detected in the websites and in the emails.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, s you have more websites on the primary server than on the slave? Where do you see that, in ISPConfig or on the shell or somewhere else?
     
  5. xanela

    xanela Member HowtoForge Supporter

    Hello again, I have checked by the shell the date of the files as well as the size of the folders. For example the main server the vmail folder occupies 89GB on the secondary server the same folder occupies only 50. In the carpedas of the websites happens the same. thank you very much. regards
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, so it is about files and not ISPConfig synchronization. How do you sync the emails between the servers, do you use dovecot sync or unison or a shared file system for /var/vmail folder?
     
  7. xanela

    xanela Member HowtoForge Supporter

    I followed the configuration manual for grouped servers,
    So I understood that both the vmail folder and the www folder were synchronized between the two ispconfig servers.
    If I'm not right, what method should I use for synchronization?
    thank you very much
     
    Last edited: Nov 11, 2017
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    That's correct when you used the mirror tutorial.
     
  9. xanela

    xanela Member HowtoForge Supporter

    if I use a mirror, but I notice that they are not synchronizing. so I do not know how I should do to recover the synchronization.
    what should I do?
     
  10. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    You should first go through the tutorial step by step again and check if everything is configured correctly. Mostly there is only some small config that was missed.
     

Share This Page