symlink to roundcube webmail displays "No input file specified."

Discussion in 'Installation/Configuration' started by bswinnerton, Mar 6, 2010.

  1. bswinnerton

    bswinnerton New Member

    symlink to roundcube webmail displays "No input file specified."

    I've created a symlink to the /webmail directory on my main website on all of my client's websites. It works fine on the main website, but on all of the client sites it says: "No input file specified."
     
  2. falko

    falko Super Moderator

    Are symlinks allowed for the virtual hosts?
     
  3. bswinnerton

    bswinnerton New Member

    I'm not sure, here is what's in mysite.com.vhost file:

    <Directory /var/www/criticalwire.com/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>
    <Directory /var/www/clients/client1/web1/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>
     
    Last edited: Mar 6, 2010
  4. falko

    falko Super Moderator

    Hm, symbolic links are allowed... Are there any errors in Apache's error log?
     
  5. bswinnerton

    bswinnerton New Member

    Here we go:

    Code:
    [Sun Mar 07 10:55:25 2010] [notice] mod_fcgid: call /var/www/site1.com/web/webmail/index.php with wrapper /var/www/php-fcgi-scripts/web7/.php-fcgi-starter
    ..not that I can make any sense out of it.
     
  6. falko

    falko Super Moderator

    Oh, you're using mod_fcgid. I guess it is a permissions problem because /var/www/site1.com/web/webmail/index.php isn't owned by the correct user and group.
     
  7. bswinnerton

    bswinnerton New Member

    Hmm, well who should it be owned by?

    I wasn't unaware that I was using the mod to be honest.
     
    Last edited: Mar 8, 2010
  8. falko

    falko Super Moderator

    The problem is that each mod_fcgid web site requires another user and group. I think it's better to use mod_php in this case.
     
  9. bswinnerton

    bswinnerton New Member

    Still no luck, same problem when I changed it to mod_php.

    EDIT: Forgot to add it to mod_php to the client. But now I'm getting a screen when trying to view the webmail page on the client.
     
    Last edited: Mar 9, 2010
  10. bswinnerton

    bswinnerton New Member

    With the following in the error.log of the client:

    Code:
    [Tue Mar 09 12:23:13 2010] [error] [client 192.168.1.50] PHP Fatal error:  Unknown: Failed opening required '/var/www/clientsite.com/web/webmail/index.php' (include_path='.:/usr/share/php:/usr/share/pear') in Unknown on line 0
    
     
  11. bswinnerton

    bswinnerton New Member

    This is super frustrating. It's obviously a permissions error, but I can't seem to figure out what permissions to give to one; the symlink, and two the webmail folder everyone is being directed to.
     
  12. bswinnerton

    bswinnerton New Member

    This was the only way I was able to resolve the problem:

    edit /etc/apache2/sites-enabled/sitename.com.vhost

    and change to:

    Code:
    php_admin_value open_basedir none
    Is this safe to do? And if so, how can I make it so that it automatically does this when it creates a new site?
     

Share This Page