symlink problem... Symbolic link not allowed

Discussion in 'General' started by zokahn, Jan 10, 2007.

  1. zokahn

    zokahn New Member

    Hi,

    At the moment i´m migrating sites to new hardware. copying files and making stuff work. I use geeklog in many cases.

    I´ve made geeklog work by replacing the /local/www/web#/web dir to a symlink pointing to /local/www/web#/geeklog/public_html Normaly that works. but now on one particular site i get a forbidden error and this is in my log:

    [Wed Jan 10 22:34:00 2007] [error] [client 123.123.123.123] Symbolic link not allowed: /local/www/web#/web

    It´s a mystery to my why one site works while another does not.

    Gr,
    Zokahn
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Does this website has a .htaccess file or any additional settings in the apache directives field? Or does all other sites have some additional settings in .htaccess or apache directives field?
     
  3. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Do you have in either apache2.conf or a .htaccess or the ISPConfig web directives specified
    Code:
    Options +FollowSymLinks
    for this directory?
     
  4. zokahn

    zokahn New Member

    I'll try it. However i did nothing of this kind to other dirs or files for the sites that do work. It's also a bit strange that the error is about the document root (the /local/www/web#/web dir itself)

    I would expect that the directives would be active for only the /local/www/web#/web subdirs. But that maybe false...

    gr,
    Zokahn
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats why I asked for this informnation:

    http://www.howtoforge.com/forums/showpost.php?p=55913&postcount=2
     
  6. zokahn

    zokahn New Member

    Thanks for looking into this... I think the problem is with the website i'm trying to setup.

    I tried to link to a new dir with just one html file, that works perfectly. Sooooo the problem is nog ispconfig related.

    Again thanks for your time.

    Gr,
    Bart:)
     

Share This Page