Symbolic link not allowed or link target not accessible: /var/www/ispconfig

Discussion in 'ISPConfig 3 Priority Support' started by toyinal, Sep 17, 2013.

  1. toyinal

    toyinal Member HowtoForge Supporter

    After installation of IPSConfig 3 on a dedicated server running CentOS 6.4, I get this error when I access https://mydomain.com:8080

    Forbidden

    You don't have permission to access / on this server.

    the apache error log is listed below:

    [Tue Sep 17 11:02:00 2013] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Tue Sep 17 11:02:00 2013] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Tue Sep 17 11:02:00 2013] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Tue Sep 17 11:02:00 2013] [notice] Digest: generating secret for digest authentication ...
    [Tue Sep 17 11:02:00 2013] [notice] Digest: done
    [Tue Sep 17 11:02:00 2013] [notice] mod_python: Creating 4 session mutexes based on 1024 max processes and 0 max threads.
    [Tue Sep 17 11:02:00 2013] [notice] mod_python: using mutex_directory /tmp
    [Tue Sep 17 11:02:00 2013] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Tue Sep 17 11:02:00 2013] [notice] Apache/2.2.15 (Unix) DAV/2 mod_fcgid/2.3.7 PHP/5.5.3 mod_python/3.3.1 Python/2.6.6 mod_ruby/1.3.0 Ruby/1.8.7(2011-06-30) mod_ssl/2.2.15 OpenSSL/1.0.0-fips configured -- resuming normal operations
    [Tue Sep 17 11:07:47 2013] [error] [client x.x.x.x] Symbolic link not allowed or link target not accessible: /var/www/ispconfig
    [Tue Sep 17 11:07:48 2013] [error] [client x.x.x.x] Symbolic link not allowed or link target not accessible: /var/www/ispconfig


    Thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    - Which Tutorial did you use to prepare your server for the installation of ispconfig?
    - Is /var/www a folder or a symbolic link?
    - Please post the ouput of:

    ls -la /var/www

    and

    ls -la /usr/local/ispconfig/interface/
     
  3. toyinal

    toyinal Member HowtoForge Supporter

    ls -la /var/www

    drwxr-xr-x 10 root root 4096 Sep 16 12:22 .
    drwxr-xr-x 24 root root 4096 Sep 17 00:30 ..
    drwxr-xr-x 2 ispapps ispapps 4096 Sep 16 12:18 apps
    drwxr-xr-x 2 root root 4096 Aug 13 19:30 cgi-bin
    drwxr-xr-x 3 root root 4096 Sep 13 15:37 error
    drwxr-xr-x 11 root root 4096 Sep 13 19:32 html
    drwxr-xr-x 3 root root 4096 Sep 16 00:35 icons
    lrwxrwxrwx 1 root root 34 Sep 16 12:22 ispconfig -> /usr/local/ispconfig/interface/web
    drwxr-xr-x 3 root root 4096 Sep 15 23:55 manual
    drwxr-xr-x 4 root root 4096 Sep 16 12:22 php-fcgi-scripts
    drwxr-xr-x 2 webalizer root 4096 Sep 16 04:30 usage


    [# ls -la /usr/local/ispconfig/interface/
    total 32
    drwxr-x--- 7 ispconfig ispconfig 4096 Sep 16 12:22 .
    drwxr-x--- 4 ispconfig ispconfig 4096 Sep 16 12:22 ..
    drwxr-x--- 2 ispconfig ispconfig 4096 Sep 16 12:22 cache
    -rwxr-x--- 1 ispconfig ispconfig 169 Sep 16 12:22 index.htm
    drwxr-x--- 5 ispconfig ispconfig 4096 Sep 16 12:22 lib
    drwxr-x--- 2 ispconfig ispconfig 4096 Sep 16 12:22 ssl
    drwxr-x--- 2 ispconfig ispconfig 4096 Sep 16 12:22 tools
    drwxr-x--- 20 ispconfig ispconfig 4096 Sep 17 11:11 web
    #


    I use Perfect Server ISPConfig 3 on Centos

    Thanks
     
    Last edited: Sep 17, 2013
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if your server uses a modified apache configuration which has FollowSymlinks globally disabled. Edit the file /etc/httpd/conf/sites-available/ispconfig.conf and add the line:

    Options +FollowSymLinks

    after the line:

    <Directory />

    Then restart apache.
     
  5. toyinal

    toyinal Member HowtoForge Supporter

    Thanks a lot
     

Share This Page