Switching from Postfx to courier?

Discussion in 'Installation/Configuration' started by MostHostLA, Jan 8, 2014.

  1. MostHostLA

    MostHostLA New Member

    I guess a better title would have been "getting rid of dovecot"? But I'm kind of helping my self through writing out where I went wrong here.

    So, I'm by no means a server expert but I'm somewhat savvy. I started installing my CentOs 6.0 x64 server following - apparently - a wrong tutorial.
    (Chapter 10 Install Dovecot NB: dovecot is indeed version 2.0.9.)
    When squirrel mail was not working correctly I realized something was amiss, so I started poking around until I eventually found - what I assume to be - the correct how-to.
    (chapter 10, First remove Dovecot (CentOS 6.0 comes with Dovecot 2.x; unfortunately, ISPConfig 3 supports Dovecot 1.2.x, but not 2.x))

    Now I'm kind of in a pickle I can't figure out.
    Initially Squirrel mail would not allow users to log in. But I have poked around courier a bit and it now allows users to log in. However the page it self is just returning a
    ERROR: Connection dropped by IMAP server.
    Query: SUBSCRIBE "INBOX.Sent"[code] error.
    I'm assuming this is due to the fact that the control panel (or is it squirrel mail? it's kind of a tossup) is trying to use Postfx which was removed as following the tutorial I believe to be correct.
    There's all sorts of error messages here and there in regards to postfx and imap such as
    Jan 8 04:15:02 ns1 postfix/smtpd[1255]: connect from localhost[::1]
    Jan 8 04:15:02 ns1 postfix/smtpd[1255]: warning: SASL: Connect to private/auth failed: Connection refused
    Jan 8 04:15:02 ns1 postfix/smtpd[1255]: fatal: no SASL authentication mechanisms
    Jan 8 04:15:03 ns1 postfix/master[11441]: warning: process /usr/libexec/postfix/smtpd pid 1255 exit status 1
    Jan 8 04:15:03 ns1 postfix/master[11441]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
    I'm not really sure what to do here, I tried all I know, I tested piecing parts together from other tutorials. The last thing I did - which seems to have helped a bit - was to re-download ISPConfig and run the config utility to reset it's variables and what not. That too seem to have some issue of sorts with Mailman, but even if it did it continued through rater smoothly.
    I'm checking into just getting a secondary hard drive to backup the website data I already uploaded and order an OS reload as I think that's the direction it's headed anyway due to the boot partition being way too small, however if someone can help out with suggestions that would be great.
    If you need the contents of the logs or whatever, just ask - possibly provide the name of the log for centOS so I can locate it and post it's contents. I'm not at all familiar with the OS as I'm coming from a red hat server and everything seems slightly different just enough to throw me off.

    - Addendum - As I keep poking at it I find more issues
    Had lines commented out for submission and smtps - following the advice on here http://www.howtoforge.com/forums/showthread.php?t=61657 I uncommented and rebooted. Still getting nowhere with squirrel mail.

    - I believe I have narrowed down the problem to actually being the authentication process in further detail.
    Following the readme for SASL to figure out what was amiss http://www.postfix.org/SASL_README.html

    Downloading dovecot again didn't really change much per-se but I am seeing a few different messages now
    Jan 8 07:24:08 ns1 postfix/master[2160]: warning: process /usr/libexec/postfix/smtpd pid 2428 exit status 1
    Jan 8 07:24:08 ns1 postfix/master[2160]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
    Jan 8 07:28:53 ns1 maildrop[2909]: Unable to open mailbox.
    Jan 8 07:28:53 ns1 maildrop[2908]: Unable to open mailbox.
    And any time I try to log in to squirrel mail it cycles this code:
    Jan 8 07:29:10 ns1 imapd: LOGIN, [email protected], ip=[::1], port=[38643], protocol=IMAP
    Jan 8 07:29:10 ns1 imapd: LOGOUT, [email protected], ip=[::1], headers=0, body=0, rcvd=30, sent=238, time=0
    Jan 8 07:29:11 ns1 imapd: Connection, ip=[::1]
    Well going to sleep now. If anything I might try to implement Cyrus and saslauthd tomorrow to see if I can resolve or savage this.
    Last edited: Jan 8, 2014
  2. MostHostLA

    MostHostLA New Member

    server reloaded

    So, I finally decided to get on with the os reload as I kept goning in circles.
    The idea of following the rame for cyrus helped a lot however, so if you are stuck and reload is not an option you should consider following through with the rest of that.

    After following the wrong/right tutorial for centOS 6.4 x86 however the mail results were very, very similar. Squirrel mail was still not logging on, the mail log was still full of errors; however this time the right error to Google was present as well.
    Mar 21 22:35:02 pluto dovecot: auth: Error: Can't open configuration file /etc/dovecot-sql.conf: No such file or directory

    Basically the cfg files are not located in the correct location for dovecot-sql, and following the tip from Hairy
    I was able to get imap in working order.
    Using Dovecot which is therefore obviously supported by ispconfig3....
    Last edited: Jan 10, 2014

Share This Page