Switch vsftp to proftp?

Discussion in 'Installation/Configuration' started by Ben, Jul 26, 2006.

  1. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Due to the fact that I am expecriencing some problems with vsftpd (endless time on starting the connection, connection aborts on transfer...) i decided to switch from vsftpd to proftp but i did not find any howtos or thread here on how to do that the best way.
    Any suggestions / links?
     
  2. TheRudy

    TheRudy ISPConfig Developer ISPConfig Developer

    Remove vsftp, install proftpd, run it (might want to do whats in the perfect setups) and go to Management -> Settings -> FTP and change paths.. That should be it..
     
  3. Ben

    Ben ISPConfig Developer ISPConfig Developer

    So the configs are automatically created then?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The config file is created automatically, but you will have to add this line at the end of your proftpd.conf file:

    Include /etc/proftpd_ispconfig.conf
     
  5. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Ok proftpd works fine up to here.

    But the daeomon stuff in the admin panel does not work for ftp.
    At first i Changed to standalone instead of ispconfig_tcpserver becaue I installed proftpd as standalone, not running with inetd.
    But that did no help anything.

    The log correctly says sth. about root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 696: /etc/init.d/proftpd restart &> /dev/null
    etc. But anything I do with stopping or starting does not effect the status of the server, its still running.

    So where should I take a look at?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please resatrt ISPConfig:

    /etc/init.d/ispconfig_server restart

    then check with:

    netstat -tap

    which FTP server is listening on the FTP port.
     
  7. Ben

    Ben ISPConfig Developer ISPConfig Developer

    after stoppin proftp, restarting tcpserver ispconfig_tcpserver ist listening ont port 21.
    And this is more than bad, because if does not accept ftp connections, with the message:
    tcpserver: warning: dropping connection, unable to run /etc/vsftpd_xxxxxx.conf: access denied
    so it looks like there is still some rest from moving to proftp.

    EDIT: looked inside the DB, nothing that I saw in isp_server that pointed to vsftpd, changed standalone back to ispconfig_tcpserver with the same result. Also a grep vsftpd * -iR in /home/admispconfig and /root/ispconfig onyl show vars from the code but no constants.... the where the hell does this vsftp stand?

    Changing from standalone it does neither shows anything nor it wokrs :-\
     
    Last edited: Jul 27, 2006
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Please set the ftpserver back to standalone and cahnge vsftpd to proftpd.

    Then Execute:

    /etc/init.d/ispconfig_tcpserver stop

    and then restart proftpd:

    /etc/init.d/proftpd restart
     
  9. Ben

    Ben ISPConfig Developer ISPConfig Developer

    I did not switch back to vsftpd so I don't know why that should be the case..
    So I just commited the options in hte vtp tab, after changing to standalone...

    The rest I did as described and proftpd is up.

    Ok it seems to work now. I thing I was a bit dazzled by the message that ftp should be online, because ony after a reload of the service page after stopping the daemon it displays offline... but now even that does not appear... don't know what was wrong.. :-\

    thx


    EDIT: Forgot one thing, after changing, even with the checkbox logs, the logentry in the DB is not beeing updated. Did it manually.

    Strange thing left is that even IdentLookups is set to off it makes ident requests.... now I dropped them with tcp-reset and the login is fast again ;)
     
    Last edited: Jul 27, 2006
  10. Ben

    Ben ISPConfig Developer ISPConfig Developer

    One last question, is it ok, taht ispconfig_tcpserver is not running anymore after that change?
    Because after stopping and strting it says startet but not listet in the processlist.

    If I take a look at the init script it looks like only beeing used for starting vsftpd, is that right?
     
  11. falko

    falko Super Moderator ISPConfig Developer

    Yes, ispconfig_tcpserver is used for vsftp only.

    Have a look here: http://www.howtoforge.com/forums/showthread.php?t=5661&highlight=IdentLookups
     

Share This Page