switch to mod_php not working?

Discussion in 'Installation/Configuration' started by Ben, May 30, 2012.

  1. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Hi guys,

    just installed a new server with debian 6 and ispcfg 3.0.4.5. I also cross check the settings with the ones that can be found in the perfect setup just to make sure everything should be fine to work well with the control panel.

    Anyhow I face the problem that in neither webpage the switch for the type of php is working properly. In all cases php is used as cgi (phpinfo output for server api: CGI/FastCGI). Also the vhost file does not change at all.
    The only switch for php what is working is disabling php.

    Any ideas what to check next?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Edit the apache suphp config file in /etc/apache2/conf.d/ and check if it contains a addtype statement for .php files, this addtype stamement should be commented out.
     
  3. Ben

    Ben ISPConfig Developer ISPConfig Developer

    So this should end up with no addtype in the vhost's config when setting php to mod_php and in case of suphp there should be this addtype line (like it currently is), right?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No, the addtype is set by ispconfig for each php type in the vhost, it does not matter if you use mod_php or suphp. See vhost file template. Just remove the global addtype in the config file I pointed out.
     
  5. Ben

    Ben ISPConfig Developer ISPConfig Developer

    thanks for the hint. I assume you mean the suphp.conf in /etc/apache2/mods-available/ (or the symlinkg in mods-enabled).

    I commented this line out, so now php is used as mod_php.

    But the problem just changed. Now I have mod_php or no php, but all other choices in the drop down do not change the behaviour.

    Any idea why the checkbox does not result in any change?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the vhost file of the affected site to see whoch php mode is enabled for that vhost.
     
  7. Ben

    Ben ISPConfig Developer ISPConfig Developer

    hmm might be that I have not waited long enough, anyhow I missed the point that the cron processes the changes thus I have to wait at least a minute.

    so the only error was the addhandler thing. Shall I report this to the bugtracker or will it be fixed in the next release anyway?
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats not a issue in ispconfig, the file is from suphp debian package. The ispconfig generated files are fine and when you follow the perfect setup guide to install ispconfig hn your server will work out of the box.
     

Share This Page