SuSE + Postfix = some mails get lost

Discussion in 'Installation/Configuration' started by v8hadas, Nov 28, 2007.

  1. v8hadas

    v8hadas New Member

    Hi There,

    I just configured my first mailserver ever based on the perfect suse setup posted on your page. It looks to be working fine, at least all incoming mails arrive.
    However unfortunately I have problems with the SMTP server. The situation is that in my country port 25 is disabled as default (the communication authority made this rule) so I run on a different port.
    First I installed ISPConfig to see if it worths using it. Then I sent some mails which arrived to a hotmail address and another addresses. Then I removed ISPConfig (make uninstall). From that moment of time I found that mails do not arrive to hotmail anymore and some of the mails get delivered to other addresses and some do not.
    I checked the /var/log/mail and such log files and it looks that all destinations return 250 mail queued but those mails do not arrive for over three days now and also there is no mailer daemon response at all - so as a sender I would assume that everything is fine.

    Do you have a clue what is going on?

    Thanks :)
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    After you removed ISPConfig, you will now have to configure the postfix settings manually in /etc/postfix/virtusertable and /etc/postfix/local-host-names. Dont forget to ceate the new hash database after you edit the virtusertable. Also you will have to make sure that you create procmail recipes manually, if you want to redirect any mail or filter it.

    The esaiest solution for you might be to just reinstall ISPConfig if you are not familar with manual postfix configuration.
  3. v8hadas

    v8hadas New Member


    Hi There,

    I just did that and the mail did not arrive again. However, I did some more tests and it looks that reply mails arrive back to hotmail.
    So the situation is:
    my postfix->hotmail = do not arrive
    hotmail->my postfix->hotmail = arrives to both my postfix and hotmail too

    Strange.... What can be possibly wrong here?

  4. v8hadas

    v8hadas New Member

    I removed ISPConfig, reconfigured postfix as per the perfect config tutorial and the situation is the same, mails arrive to hotmail only if those are reply to previously sent messages from hotmail. Other mails to other mail servers seem to be getting lost randomly like 1 out of 10 or so. :eek:
  5. v8hadas

    v8hadas New Member

    And one last thing I worry about, this is the report from /var/log/mail:

    Nov 29 22:21:12 dualxeon postfix/smtp[28756]: 0A4E5256832C: to=<[email protected]>,[]:25, delay=1
    .7, delays=0.43/0.01/0.63/0.67, dsn=2.0.0, status=sent (250 <005c01c832c5$5b25d010$6400a8c0@lsyzv66s59ff3o> Queued mail for delivery)
    Nov 29 22:21:12 dualxeon postfix/qmgr[28715]: 0A4E5256832C: removed
    Nov 29 22:21:13 dualxeon postfix/smtp[28755]: 714142568318: to=<[email protected]>,[]:25, delay=4
    .6, delays=0.51/0.01/1.2/2.9, dsn=2.0.0, status=sent (250 <005801c832c5$5a350770$6400a8c0@lsyzv66s59ff3o> Queued mail for delivery)
    Nov 29 22:21:13 dualxeon postfix/qmgr[28715]: 714142568318: removed

    The first mail was received, the second was not. I wonder what is going on... :eek:

Share This Page