Suse 11 Postfix odball problem

Discussion in 'Server Operation' started by paulsaenze, Mar 16, 2009.

  1. paulsaenze

    paulsaenze New Member

    Running Suse 11 and Postfix I've followed all the instructions in The Perfect Server here at howtoforge and have things running beautifully. TLS is good in mail. I can send mail using that account from a client. I can send mail into that account from outside. However, when I log in from a client, knowing there is mail on the machine because I can see it from the command line, the client reports no new mail on the server. The mail log says that the client did log in and then log out. In main.cf, the mail spool directory is /var/mail (tried /var/spool/mail with no success).

    Excerpts from main.cf:
    mailbox_command = /usr/bin/procmail -Y $DOMAIN
    mailbox_transport =
    <could the above be wrong?>
    home_mailbox = Maildir/ <this exists>

    I don't know where to look to solve this. Ideas?

    Tx, Paul Seanze
     
  2. paulsaenze

    paulsaenze New Member

    Addendum

    I should have said above that "client" means from another machine altogether.
     
  3. falko

    falko Super Moderator ISPConfig Developer

    What POP3 daemon are you using? What's the output of
    Code:
    netstat -tap
    ?
     
  4. paulsaenze

    paulsaenze New Member

    output of netstat -tap

    With a couple of things removed to prevent spammers

    netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:imaps *:* LISTEN 2571/couriertcpd
    tcp 0 0 *:pop3s *:* LISTEN 2617/couriertcpd
    tcp 0 0 localhost:809 *:* LISTEN 2753/famd
    tcp 0 0 *:mysql *:* LISTEN 2506/mysqld
    tcp 0 0 *:pop3 *:* LISTEN 2598/couriertcpd
    tcp 0 0 *:imap *:* LISTEN 2555/couriertcpd
    tcp 0 0 *:sunrpc *:* LISTEN 2435/portmap
    tcp 0 0 *:www-http *:* LISTEN 4959/httpd2-prefork
    tcp 0 0 *:ssh *:* LISTEN 2724/sshd
    tcp 0 0 localhost:ipp *:* LISTEN 2668/cupsd
    tcp 0 0 *:smtp *:* LISTEN 6460/master
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Please run
    Code:
    postconf -e 'home_mailbox = Maildir/'
    postconf -e 'mailbox_command ='
    /etc/init.d/postfix restart
     
  6. paulsaenze

    paulsaenze New Member

    Did that

    Now it works. Thanks mucho Falko!
     

Share This Page