Discussion in 'Installation/Configuration' started by planet_fox, Dec 16, 2006.

  1. planet_fox

    planet_fox Member

    hm Falco Just I have create in a web a order with phpini, i have post config for the vhost

    ServerAdmin [email protected]
    DocumentRoot /home/www/web10/web
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.jsp Default.htm default.htm
    ScriptAlias  /cgi-bin/ /home/www/web10/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /home/times/web10/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    suPHP_Engine on
    suPHP_ConfigPath /home/www/web10/phpini/
    suPHP_UserGroup web10_ftp web10
    AddHandler x-httpd-php .php .php3 .php4 .php5
    suPHP_AddHandler x-httpd-php
    Alias /error/ "/home/www/web10/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /home/www/web10/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /home/www/web10/user/$1/web/$3
    The fucking is I must for OScomerce run register globals on

    FATAL ERROR: register_globals is disabled in php.ini, please enable it!

    So many problems with this shop, I don 't now why osc developer do not resolve this problems. OMG
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you want to get a answer or a answer from Falko ;) Falko is in xmas hollidays.

    According to the suphp website, the config path directive shall have no / at the end. Please try:

    suPHP_ConfigPath /home/www/web10/phpini

    Please post the output of:

    ls -la /home/www/web10/phpini
  3. planet_fox

    planet_fox Member

    -rw-r--r-- 1 web10_ftp web10 38594 Dec 16 22:52 php.ini
  4. falko

    falko Super Moderator ISPConfig Developer

    suPHP_ConfigPath /home/www/web10/phpini/
    This directive is for the suPHP configuration file, but not for php.ini. This is a big difference.
  5. planet_fox

    planet_fox Member

    Ok, how I can register globals=on for in this web ? and I have see when I do register globals on in /etc/php4/cgi/php.ini and restart apache2. No change do it. ok and a new problem i can only root login.
  6. falko

    falko Super Moderator ISPConfig Developer

  7. planet_fox

    planet_fox Member

    When I do create .htaccess file and do into

    php_flag register_globals on
    came error 500

    whats permisson musst have permisson of administrator ?
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    This is not a problem with user permissions.

    You must allow the usage of php flags in .htaccess files by settting a appropriate AllowOverride directive in your apache configuration. For test purposes, you can set it to

    AllowOverride All
  9. planet_fox

    planet_fox Member

    ok I have found a patch for servers with register_globals off for oscomerce. I have upload and it run
  10. lostmail

    lostmail New Member

    What patch is it and where did you find it - can you post the patch here ?

Share This Page