suPHP with SSL

Discussion in 'General' started by Norman, Jun 16, 2009.

  1. Norman

    Norman Member HowtoForge Supporter

    I'm running Perfect setup Debian Lenny with latest version of ISPConfig 3.
    Noticed an issue with running suPHP and SSL activated.

    Any request to the site with SSL activated only gives server error 500 return codes.

    In the error log for the site I found these lines:

    ue Jun 16 00:30:34 2009] [error] [client x.x.x.x] Premature end of script headers: index.php
    [Tue Jun 16 00:32:03 2009] [error] [client x.x.x.x] SecurityException in Application.cpp:440: Handler not found in configuration
    [Tue Jun 16 00:32:03 2009] [error] [client x.x.x.x] Caused by KeyNotFoundException in Configuration.cpp:234: Handler "x-httpd-php" not found


    I switched over to fastCGI instead (php) and it works fine. Any idea what may cause this ? Is there a fix so I can use suPHP with ssl?
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    There is a bug in the vhost template. In The file /usr/local/ispconfig/server/conf/vhost.conf.master around line 258 you will find these lines:

    Code:
        suPHP_Engine on
        # suPHP_UserGroup <tmpl_var name='system_user'> <tmpl_var name='system_group'>
        AddHandler x-httpd-php .php .php3 .php4 .php5
        suPHP_AddHandler x-httpd-php
    replace it with:

    Code:
            suPHP_Engine on
            # suPHP_UserGroup <tmpl_var name='system_user'> <tmpl_var name='system_group'>
            AddHandler x-httpd-suphp .php .php3 .php4 .php5
            suPHP_AddHandler x-httpd-suphp
    Then change a setting in the website in ispconfig and click on save so that the config gets rewritten.
     
  3. Norman

    Norman Member HowtoForge Supporter

    Ah :) Is this going to be fixed in next version?
     

Share This Page