suPHP problem on

Discussion in 'Installation/Configuration' started by andcar, Sep 21, 2010.

  1. andcar

    andcar New Member

    Hi all.
    My system is as follows: ISPconfig 2.2.37
    suphp (following the howto on howtoforge) version 0.7.1
    Ubuntu 8.04.4
    The problem is that the /etc/apache2/vhosts/Vhosts_ispconfig.conf created by ISPConfig has in all websites the entry
    eg. "suPHP_UserGroup nobody web20"
    instead it should be
    "suPHP_UserGroup www-data web20".
    I've made this workaround by hand (manually with a sed on the Vhost file), cause with the nobody user all the websites where giving me the error:
    eg. "Mismatch between target UID (65534) and UID (33) of file "/var/www/web20/web/index.php"
    where 65534 UID is the nobody user ID and 33 is the www-data ID.
    I've checked the /etc/suphp.conf and in there I've found the correct setting
    Please tell me if there is something else I must check.
  2. andcar

    andcar New Member


    Hi again,
    I've found the solution googling a lot.
    The problem is that every new website needs an Admin user this way ISPconfig writes the right user to the Vhost file.
    Hope that this will help someone else.

Share This Page