suphp playing up

Discussion in 'Server Operation' started by mattbrown, Sep 5, 2007.

  1. mattbrown

    mattbrown New Member

    I've just followed the how to on setting up suphp on fc7 with ispconfig and I've hit a problem right at the last bit.

    I am working with a fresh install of fc7 / ispconfig and have followed the fc7 setup referenced in the top of the suphp how to here

    Only problem is when I go to configure suphp using

    ./configure --prefix=/usr --sysconfdir=/etc --with-apr=/usr/bin/apr-1-config --with-apxs=/usr/sbin/apxs --with-apache-user=apache --with-setid-mode=paranoid --with-php=/usr/bin/php-cgi --with-logfile=/var/log/httpd/suphp_log --enable-SUPHP_USE_USERGROUP=yes

    as stated in the tutorial

    I get:

    checking for APR... configure: error: the --with-apr parameter is incorrect. It must specify an install prefix, a
    build directory, or an apr-config file.

    If i look in /usr/bin there is nothing by the name if apr-1-config and a quick search using find dosent seem to locate anything either.

    Can somebody please tell me what I'm doing wrong

  2. mattbrown

    mattbrown New Member

    ok so i solved the first problem by yum install apr-devel

    I then deleted the suphp files and extracted the zip again

    ran the configure command and everything seemed to go ok until i ran make and it jus treturned a shed load of errors

    the tail end of which is below

    mod_suphp.c:283: warning: assignment makes pointer from integer without a cast
    mod_suphp.c:337: error: 'APLOG_MARK' undeclared (first use in this function)
    mod_suphp.c:337: error: 'APLOG_ERR' undeclared (first use in this function)
    mod_suphp.c:339: warning: incompatible implicit declaration of built-in function 'exit'
    mod_suphp.c: At top level:
    mod_suphp.c:347: error: expected ')' before '*' token
    mod_suphp.c:619: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'suphp_handlers'
    mod_suphp.c:626: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'MODULE_VAR_EXPORT'
    make[3]: *** [mod_suphp.lo] Error 1
    make[3]: Leaving directory `/tmp/suphp-0.6.2/src/apache'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/tmp/suphp-0.6.2/src'
    make[1]: *** [all] Error 2
    make[1]: Leaving directory `/tmp/suphp-0.6.2/src'
    make: *** [all-recursive] Error 1
    needless to say make install does a similar thing and there is no /etc/suphp.conf

    Any input would be great
  3. rolij

    rolij New Member

    I have exactly the same problem. I followed the tutorials and it seems like installing suphp on a fresh fc7 system with ispconfig doesn't work.

    Any help would be great!
  4. mattias

    mattias New Member

    don't forget yum install httpd-devel too
    it contains apxs
    after that it should work

    the guide seems to miss out the apr-devel and httpd-devel packages
    don't know why :)

    edit: ooh, and to make httpd restart ok, comment out php_admin lines in the file
    then restart and make a small modification in ispconfig, like removing wap or enable wap on a site, it will make it write a new working Vhosts_ispconfig.conf file. and there you go :) those steps were all that was missing.

    edit edit: more steps i had to do:
    i did the CentOS 5.0 Perfect setup, so i don't know if its the same path for all, but... change session.save_path = "/var/lib/php/sessions" in /etc/php.ini to
    session.save_path = "/tmp"

    this is because, suPHP executes as the user and group of the php binary, or something like that, and /var/lib/php/sessions is owned by root:apache, and i didnt know what else to do but change to /tmp which is free for all to write in. if anyone knows a better solution i'd love to know :) my system is truly complete now as it is tho :D *finally*

    edit edit edit: ok so... this setup is perfect so far. also noticed if users can ssh, they can enter each others directories, this probably has nothing to do with suphp, but solution is:
    chmod 770 for each web directory you don't want users to enter, then set group apache to the web dirs of each user, and only the first one, so apache can read the sites... chown :apache /var/www/web5 for example

    also in /etc/security/limit.conf set good limits for the group users, and add each user to that group. i got mine so they can use 5 minutes cpu time, and few other good stuff, still haven't find a solution to throttle disk i/o locally so they can't use all bandwidth when copying big files or something, since if the disk goes full speed, it can really make all sites on that server unresponsive, well im trying to perfect my setup. and these are the extra steps ive taken from centos 5.0 perfect setup + suphp + ispconfig
    Last edited: Nov 13, 2007

Share This Page