suPHP / PHP5 / ISP Config

Discussion in 'Installation/Configuration' started by Dy0nisus, Jan 10, 2007.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    No. Normally it sould work when it is enabled in the php.ini file:confused:
  2. Dy0nisus

    Dy0nisus New Member

    first of all i like to thank u for the fast replys!!

    i found something, but i dont know, why it's that way (out of phpinfo()):

    '../configure' '--prefix=/usr' '--enable-discard-path' '--enable-fastcgi' '--with-config-file-path=/etc/php4/cgi' '--enable-memory-limit' '--disable-debug' '--with-regex=php' '--disable-rpath' '--disable-static' '--with-pic' '--with-layout=GNU' '--with-pear=/usr/share/php' '--enable-calendar' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--enable-track-vars' '--enable-trans-sid' '--enable-bcmath' '--with-bz2' '--enable-ctype' '--with-db4' '--with-iconv' '--enable-exif' '--enable-filepro' '--enable-ftp' '--with-gettext' '--enable-mbstring' '--with-pcre-regex=/usr' '--enable-shmop' '--enable-sockets' '--enable-wddx' '--disable-xml' '--with-expat-dir=/usr' '--with-xmlrpc' '--enable-yp' '--with-zlib' '--without-pgsql' '--with-kerberos=/usr' '--with-openssl=/usr' '--with-zip=/usr' '--enable-dbx' '--with-mime-magic=/usr/share/misc/file/magic.mime' '--with-exec-dir=/usr/lib/php4/libexec' '--without-mm' '--without-mysql' '--without-sybase-ct' 

    i guess thats the problem?

    EDIT: phpinfo() also shows

    but enabled as mod:

    is that a problem too?
    Last edited: Jan 12, 2007
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats no problem. It yout means that mysql is not compiled in which is always the case for modular php installations. mysql must be lodaed as module in the php.ini file.

    Is there a php.ini file in the directory /etc/php4/cgi/ and is php enabled in tis php.ini file?
  4. Dy0nisus

    Dy0nisus New Member

    ok ...

    yes there is! to mysql it says:

    ; Allow or prevent persistent links.
    mysql.allow_persistent = On
    ; Maximum number of persistent links.  -1 means no limit.
    mysql.max_persistent = -1
    ; Maximum number of links (persistent + non-persistent).  -1 means no limit.
    mysql.max_links = -1
    ; Default port number for mysql_connect().  If unset, mysql_connect() will use
    ; the $MYSQL_TCP_PORT or the mysql-tcp entry in /etc/services or the
    ; compile-time value defined MYSQL_PORT (in that order).  Win32 will only look
    ; at MYSQL_PORT.
    mysql.default_port =
    ; Default socket name for local MySQL connects.  If empty, uses the built-in
    ; MySQL defaults.
    mysql.default_socket =
    ; Default host for mysql_connect() (doesn't apply in safe mode).
    mysql.default_host =
    ; Default user for mysql_connect() (doesn't apply in safe mode).
    mysql.default_user =
    ; Default password for mysql_connect() (doesn't apply in safe mode).
    ; Note that this is generally a *bad* idea to store passwords in this file.
    ; *Any* user with PHP access can run 'echo get_cfg_var("mysql.default_password")
    ; and reveal this password!  And of course, any users with read access to this
    ; file will be able to reveal the password as well.
    mysql.default_password =
    ; Maximum time (in seconds) for connect timeout. -1 means no limit
    mysql.connect_timeout = 60
    ; Trace mode. When trace_mode is active (=On), warnings for table/index scans and
    ; SQL-Errors will be displayed.
    mysql.trace_mode = Off

    maybe i shuld enable this extention?!
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, you must thenable the extension by removing the ; iin front of the line:

  6. Dy0nisus

    Dy0nisus New Member

    ahh ok ...

    strange thing:

    i enabled and restarted apache ... ok.

    then i could not connect to any web ... then i disabled ist again and restartet
    apache2 ... now it works with mysql and no errors yet ...

    big thank you :D

Share This Page