suphp on debian etch error

Discussion in 'Installation/Configuration' started by Alex1, Jun 1, 2007.

  1. Alex1

    Alex1 New Member

    Forcing reload of web server (apache2)...Syntax error on line 55 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
    Invalid command 'php_admin_flag', perhaps misspelled or defined by a module not included in the server configuration
    failed!


    it is php_admin_flag safe_mode on/off value
     
    Last edited: Jun 1, 2007
  2. Hans

    Hans Moderator ISPConfig Developer

    Migration to suPHP on your ISPConfig server

    Hi,
    If you want to setup suPHP on your ISPConfig server please take exactly the steps (and in the right order) as mentioned within: http://www.howtoforge.com/suphp_debian_etch_ispconfig

    Probably you forget to remove the admin entries within your Vhosts_ispconfig.conf.
    After removing those admin entries, please retart Apache2 again.
     
  3. Alex1

    Alex1 New Member

    i do it
    but some vhosts are already present on the file so on them there is the entry php_admin_flag safe_mode
    so at restart before
    Code:
    Edit /home/admispconfig/ispconfig/lib/config.inc.php find the line:
    i've that error
     
  4. Alex1

    Alex1 New Member

    ok i solved that part ... i manually remove php_admin flag record but when i edit

    $go_info["server"]["apache2_php"] = 'suphp';


    no modification are done on my Vhost file
     
  5. Hans

    Hans Moderator ISPConfig Developer

    That's correct.
    You can force ISPConfig to make a modification to your vhost-file by changing a setting within one of your sites on within ISPConfig.
    For example enable cgi or standard-cgi for a website.
     

Share This Page