suPHP Issues.Please help

Discussion in 'Installation/Configuration' started by u4david, Sep 28, 2010.

  1. u4david

    u4david New Member

    SecurityException in Application.cpp:511: Unknown Interpreter: Premature end of script headers: index.php


    This is my log files.

    I'm sure it have to do with Suphpthat I enabled.
    Any tips.

    Some tips that i have in my head to may try
    -disabling php globaly
    -is php isnatlled at all
    -config files?

    Not sure what to do here.

    Thank you
     
  2. till

    till Super Moderator

    Please post the suphp.conf file.
     
  3. u4david

    u4david New Member

    suphp.conf

    [global]
    ;Path to logfile
    logfile=/var/log/suphp/suphp.log

    ;Loglevel
    loglevel=info

    ;User Apache is running as
    webserver_user=www-data

    ;Path all scripts have to be in
    docroot=/var/www:${HOME}/public_html

    ;Path to chroot() to before executing script
    ;chroot=/mychroot

    ; Security options
    allow_file_group_writeable=false
    allow_file_others_writeable=false
    allow_directory_group_writeable=false
    allow_directory_others_writeable=false

    ;Check wheter script is within DOCUMENT_ROOT
    check_vhost_docroot=true

    ;Send minor error messages to browser
    errors_to_browser=false

    ;PATH environment variable
    env_path=/bin:/usr/bin

    ;Umask to set, specify in octal notation
    umask=0022

    ; Minimum UID
    min_uid=100

    ; Minimum GID
    min_gid=100


    [handlers]
    ;Handler for php-scripts
    application/x-httpd-suphp="php:/usr/bin/php-cgi"

    ;Handler for CGI-scripts
    x-suphp-cgi="execute:!self"
    x-httpd-suphp=php:/usr/bin/php-cgi




    ispconfig 3.0.2.2
    ubuntu 10.04 LTS
    Fresh install

    Location /etc/suphp/suphp.conf
    root is the owner and group
     
  4. till

    till Super Moderator

    Please edit the line:

    x-httpd-suphp=php:/usr/bin/php-cgi

    in suphp.conf and change it to:

    x-httpd-suphp="php:/usr/bin/php-cgi"

    Then restart apache.
     
  5. u4david

    u4david New Member

    that did not work

    adding or removing the quotation = No results ,same error.
     
    Last edited: Sep 28, 2010
  6. u4david

    u4david New Member

    how about this?

    [handlers]
    ;Handler for php-scripts
    application/x-httpd-suphp="php:/usr/bin/php-cgi"


    and changing it to:
    x-httpd-suphp="php:/usr/bin/php-cgi"

    well I tell you if this worked or not

    Is this mean that ISPconfig3 scripts fail to adjust this when installed?
     
    Last edited: Sep 29, 2010
  7. u4david

    u4david New Member

    still no resolution

    still not solved =same problem

    please advise
     
  8. till

    till Super Moderator

    This means that different suphp versions ahve different configuration file requirements. Most bersions dont need this setting to be in quotes while your version might require that. Thats why I asked you to test that.
     
  9. till

    till Super Moderator

    Please post the "ls -la" output for the index.php file which is causing this error.
     
  10. till

    till Super Moderator

    And you restarted the apache webserver after the changes? The changes get applied when apache is restarted.
     

Share This Page