Suphp issue

Discussion in 'Installation/Configuration' started by edony44, Dec 1, 2006.

  1. edony44

    edony44 New Member


    I have some trouble with suphp !
    I have just notice that file must be set chmod to 755.
    I use to think that suphp should perfectyl work with 700

    But a 403 forbidden is return in this case :
    error.log :

    [Fri Dec 01 17:11:46 2006] [crit] [client] (13): /var/www/web5/web/files/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable,

    Of course all work if i make permission read file for Others .
    Any issue ?

    I've verify that the apache suphp login is the same as the file.
  2. edony44

    edony44 New Member

    No News

    I DON T find any issus over the web ... so if you know
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Your problem is not a .php file, it is this /var/www/web5/web/files/.htaccess which must be readable to the apache user. htaccess files where read by apache not php / suphp.
  4. edony44

    edony44 New Member

    and .html ... are they read by apache ? or suphp . and cgi script ? it will be useful to have a list of file that need the www-data user to be read ? thanks
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Everything except .php files has to be readable by the apache user.
  6. edony44

    edony44 New Member


    so i need to put chmod 755 for every uploaded file !
    is there any way to make ispconfig put every users ( webx_x ) in apache group ??

    Or anyway to enable file reading by apache by defaut ???

    I think that it should cause some trouble for people who want to upload their file which are not in php ?? And it will be unsure to set umask to 777 !!
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Not without changing the ISPConfig code.
  8. edony44

    edony44 New Member

    So What

    so what change should i make to the code
    should i add
    web user to www-data group or add www-data user to every webx group ... or any other solution ?
    does the problem the same with suexec
  9. edony44

    edony44 New Member


    IT doesnt seems to work ... in www-data user or group
  10. edony44

    edony44 New Member


    Is there any module for apache that let change the apache user for a virtual host ( to execute all file type with the same user as suphp )
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you want to access or execute files. Only CGI files where executed.
  12. edony44

    edony44 New Member


    To execute file which should be execute and access all the file ...

    I have found a solution .. By lookink at ispconfig code i've seen that a function add admispconfig group to all user so i've duplicated this function and change admispconfig to www-data ..
    so now when a website is create with an user ... this user got the www-data in his group so all seem to work with chmod 750 ..

Share This Page