suPHP installation problems!

Discussion in 'Installation/Configuration' started by Ohem, Jul 3, 2007.

  1. Ohem

    Ohem New Member

    Hi!

    I recently installed ISPConfig and wanted to install suPHP for making the web space for each site automatically writeable. Now since i have cloned my Unbtu with ISPConfig in VMWare i don't need to re-install after a mistake made by me.

    Anyway, here's the issue: I've followed this HOWTO: http://www.howtoforge.com/suphp_debian_etch_ispconfig done everything as it says i have to do YET i get problems on the way, such as this error:

    * Forcing reload of web server (apache2)... apache2: Syntax error on line 189 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/httpd.conf: Cannot load /usr/lib/apache2/modules/mod_suphp.o into server: /usr/lib/apache2/modules/mod_suphp.o: cannot open shared object file: No such file or directory

    I've repeated this procedure ~5 times now and still not working. And each time i've used another clone in VMWare to undo all the changes before suPHP installation.

    Apparently the file mod_suphp.o never creates, why?

    Edit:

    Geez WHAT IS WRONG WITH ME? I made a typo in httpd.conf where *.o was placed instead of *.so. Well i might get problem soon enough.

    Edit 2:

    Yep, got problems now. Alright i didn't recieve any errors in the terminal/console but i can't install the CMS system Joomla. But i do get an "Internal Server Error" (500) and whether i enable or disable php5 (according to the howto) it still won't work.

    Also, when i shut off suPHP will that as well affect the other websites? If it does, what good is that?
     
    Last edited: Jul 3, 2007
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please have a look at the error log of the website.
     
  3. Ohem

    Ohem New Member

    So much i figured but i don't see any "WARNING" parts in the logfile (ispconfig.log). Are there any other logs i should look at?

    Edit:

    The website's own logfile doesn't really tell me anything, and don't even know what to look for. Searched for "internal server error", "500" etc etc but nothing that makes sense to me.
     
    Last edited: Jul 3, 2007
  4. Hans

    Hans Moderator ISPConfig Developer

    Some suggestions

    It is very important that the steps within the howto to be taken are done within the right order!
    Where all the admin entries removed within your vhost file and is suEXEC disabled?

    If the ownership of the Joomla site is still set to www-data:www-data, you can change it with: chown -R -v -f webadmin:webXX web/*

    (Webadmin is the user with administrative rights as defined within ISPConfig and webXX is the webnumber).
     
  5. Ohem

    Ohem New Member

    I do the steps from top to bottom, but didn't figure suEXEC had to be disabled. I've now activated the clone of my ISPConfig so i will repeat the process of installing suPHP, are there any other steps i have to do before installing?
     
  6. Hans

    Hans Moderator ISPConfig Developer

    It seems that suEXEC is not comaptible with suPHP.
    There are no other steps to be taken as mentioned within the howto.

    Did you try the chown suggestion already?
    It worked for me with Joomla sites, when i megrated to suPHP. ;)
     
  7. Ohem

    Ohem New Member


    Even by deactivate suEXEC i still recieve 500 error whether suPHP is on or off. I've followed your guide as punctual as possible.

    Chown suggestion? I think i remember someone suggesting chown all the content inside the web directory as apache directive, at first it sounds good but it also mean i've to manually type it. Is there a way to "integrate" the directive command when a site is created? (and already existing ones)
     
  8. Hans

    Hans Moderator ISPConfig Developer

    I do not know such script, but i hope you can avoid the internal 500 error, by using the suggested chown command for this moment.
     
  9. Ohem

    Ohem New Member

    I performed another way of installing suphp, by the package libapache-mod-suphp.

    it installed and configured the most things, as usual i did recieve the 500 error BUT the log file was a lot better to read now, here the following:

    Code:
    [Tue Jul 03 15:54:56 2007] [error] [client CENSOREDIP] SoftException in Application.cpp:231: File "/var/www/web2/web/index.php" is writeable by group
    [Tue Jul 03 15:54:56 2007] [error] [client CENSOREDIP] Premature end of script headers: index.php
    [Tue Jul 03 15:56:48 2007] [error] [client CENSOREDIP] SoftException in Application.cpp:247: File "/var/www/web2/web/index.php" is writeable by others
     
  10. Hans

    Hans Moderator ISPConfig Developer

    What's the output of ls -la /webXX
    The directory witch contains php-scripts must have chmod 775 or 755, otherwise they can not be executed.

    Did you turn off phpmod with a2dismod php5 ?

    Remember that if you turn on phpmod, you must add some directives for Apache within the Apache directive field for that site within ISPConfig. (As mentioned within the howto).
     
    Last edited: Jul 3, 2007

Share This Page