suPHP build error

Discussion in 'HOWTO-Related Questions' started by conductive, Oct 3, 2011.

  1. conductive

    conductive Member

    suPHP build error

    I am not sure why I get this error. The download seems to be OK.
    .
    snip.....
    checking dynamic linker characteristics... GNU/Linux ld.so
    (cached) (cached) checking how to hardcode library paths into programs... immediate
    appending configuration tag "F77" to libtool
    checking if libtool supports shared libraries... yes
    checking whether to build shared libraries... yes
    checking whether to build static libraries... yes
    checking for gfortran option to produce PIC... -fPIC
    checking if gfortran PIC flag -fPIC works... yes
    checking if gfortran static flag -static works... no
    checking if gfortran supports -c -o file.o... yes
    checking whether the gfortran linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
    checking dynamic linker characteristics... GNU/Linux ld.so
    (cached) (cached) checking how to hardcode library paths into programs... immediate
    checking for ANSI C header files... (cached) yes
    checking fcntl.h usability... yes
    checking fcntl.h presence... yes
    checking for fcntl.h... yes
    checking for stdlib.h... (cached) yes
    checking for string.h... (cached) yes
    checking for unistd.h... (cached) yes
    checking for APR... configure: error: the --with-apr parameter is incorrect. It must specify an install prefix, a
    build directory, or an apr-config file.
    [[email protected] suphp-0.7.1]# make
    make: *** No targets specified and no makefile found. Stop.
    [[email protected] suphp-0.7.1]# make install
    make: *** No rule to make target `install'. Stop.

    http://www.howtoforge.com/perfect-server-centos-6.0-x86_64-ispconfig-3-p5
     
  2. conductive

    conductive Member

    The problem is that apr-1-config is missing and can not seem to find the package group containing it.

    This seems to be a new development.
    Is there something I messed up or need to change in the repo?
     
  3. conductive

    conductive Member

    The package is apr-devl but I am still missing something and I do not know what.

    .
    snip............
    mod_suphp.c:413: warning: incompatible implicit declaration of built-in function ‘exit’
    mod_suphp.c: At top level:
    mod_suphp.c:421: error: expected ‘)’ before ‘*’ token
    mod_suphp.c:505: error: expected ‘)’ before ‘*’ token
    mod_suphp.c:789: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘suphp_handlers’
    mod_suphp.c:798: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘MODULE_VAR_EXPORT’
    make[2]: *** [mod_suphp.lo] Error 1
    make[2]: Leaving directory `/tmp/suphp-0.7.1/src/apache'
    make[1]: *** [install-recursive] Error 1
    make[1]: Leaving directory `/tmp/suphp-0.7.1/src'
    make: *** [install-recursive] Error 1
     
  4. conductive

    conductive Member

    For some reason the http-devel needed reloading too.

    The php-pdo/mssql-devel problem may have contributed to this issue as well.
     
    Last edited: Oct 4, 2011
  5. falko

    falko Super Moderator ISPConfig Developer

    So you got it working?
     
  6. conductive

    conductive Member

    2 out of 3 fixes so to speak but it ended up having an unstable web server.

    I am kind of thinking that it would have worked it the php-pdo revision dependency for mssql-devel did not fail.
     

Share This Page