suPHP (again)

Discussion in 'General' started by momfer, Dec 1, 2009.

  1. momfer

    momfer New Member HowtoForge Supporter

    After installing ISPConfig 3.0.1.6 the past week, I got stuck in the suPHP config.

    "Premature end of scripts", "Handler "x-http-suphp" not found" and additionally "Handler not found in configuration"

    Tried several settings, search many webpages.

    At last I change /etc/suphp.conf

    [handlers]
    x-http-suphp = "php:/usr/bin/php-cgi5" (added the bold stuff)

    and that did the trick.

    My question is:
    Is this finally the right setting, or should i change some setting in another place?

    I hope this helps others too!
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Yes, thats the right setting. Normally ispconfig is doing this for you. Maybe you installed suphp after ispconfig or you updated suphp which overwrote the setting?
     
  3. momfer

    momfer New Member HowtoForge Supporter

    Thanks for your response Till.

    Actually neither one of them. But I am glad that you can confirm that I have the right setting.

    suPHP problem down, mail problems to go ;)
     

Share This Page