suphp-0.7.1-3.1.x86_64.rpm Failed Dependencies

Discussion in 'Installation/Configuration' started by ppssupport, Aug 17, 2010.

  1. ppssupport

    ppssupport New Member

    I'm trying to install the SUPHP on opensuse 11.3 for ISPCONFIG3 as despribe at:
    http://www.howtoforge.com/perfect-server-opensuse-11.3-x86_64-ispconfig-3-p4
    Section:
    10 Install The Apache 2 Webserver And PHP5

    code I ran is:
    rpm -ivh http://download.opensuse.org/reposi...enSUSE_11.3/x86_64/suphp-0.7.1-3.1.x86_64.rpm

    Error output
    libc.so.60(64bit) is needed by suphp-G.7.1-3.1.x86_64
    libc.so.6(GLIBC_Z.Z.5)(64bit) is needed by suphp-Q.7.1-3.1.x86_64 libc.so.6(GLIBC_Z.4)(64bit) is needed by suphp-Q.7.1-3.1.x86_64
    1ibgccs.so.1()t64bit) is needed by suphp-Q.7.1-3.1.x86_64 libgcc_s.so.l(GCC_3.G)(64bit) is needed by suphp-Q.7.1-3.1.x86_64
    1ibpthread.so.GO(64bit) is needed by suphp-Q.7.1-3.1.x86_64
    1ibstdc++ .so .60 (64bit) is needed by suphp-G.7 .1-3.1.x86_64 libstdc++.so.6(CXXABI_1.3)(64bit) is needed by suphp-Q.7.1-3.1.x86_64 libstdc++.so.6(CXXABI_1.3.1)(64bit) is needed by suphp-Q.7.1-3.1.x86_64 libstdc++.so.6(GLIBCXX_3.4)(64bit) is needed by suphp-Q.7.1-3.1.x86_64 libstdc++.so.6(GLIBCXX_3.4.11)(64bit) is needed by suphp-Q.7.1-3.1.x86_64 libstdc++.so.6(GLIBCXX_3.4.9)(64bit) is needed by suphp-Q.7.1-3.1.x86_64

    Please help me out
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    uname -a
    ?
     
  3. ralphot

    ralphot New Member

    I have the same problem. SUPHP install

    uname -a gives:

    Linux surte 2.6.34-0.1-default #1 SMP 2010-08-20 19:21:29 +0200 i686 i686 i386 GNU/Linux

    The command:

    rpm -ivh http://download.opensuse.org/reposi...enSUSE_11.3/x86_64/suphp-0.7.1-3.1.x86_64.rpm

    In these instructions:

    http://www.howtoforge.com/perfect-server-opensuse-11.3-x86_64-ispconfig-3-p4

    My processor is 32-bit. Maybe I need 64-bit processor to succeed?
    It must be able to run a server on 32-bit machines?? Do I have to fetch 32-bit components?

    Please help
     
    Last edited: Sep 11, 2010
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You try to install a 64Bit binary on a 32bit system, so this can not work. You will have to install a 32Bit RPM.

    The guide that you used id for 64Bit systems, so it will not work for your server. But you can try to search in the opensuse repositorys for a 32Bit version of the rpm's that you need.
     
  5. ralphot

    ralphot New Member

    Thanks.

    Understand fully.
     
  6. oprea.alex

    oprea.alex New Member

    Failed Dependencies libc.so.6

    Hello,

    I have the same problem
    rpm -ivh http://download.opensuse.org/reposi...enSUSE_11.3/x86_64/suphp-0.7.1-3.3.x86_64.rpm
    Retrieving http://download.opensuse.org/reposi...enSUSE_11.3/x86_64/suphp-0.7.1-3.3.x86_64.rpm
    error: Failed dependencies:
    libc.so.6()(64bit) is needed by suphp-0.7.1-3.3.x86_64
    libc.so.6(GLIBC_2.2.5)(64bit) is needed by suphp-0.7.1-3.3.x86_64
    libc.so.6(GLIBC_2.4)(64bit) is needed by suphp-0.7.1-3.3.x86_64
    libgcc_s.so.1()(64bit) is needed by suphp-0.7.1-3.3.x86_64
    libgcc_s.so.1(GCC_3.0)(64bit) is needed by suphp-0.7.1-3.3.x86_64
    libpthread.so.0()(64bit) is needed by suphp-0.7.1-3.3.x86_64
    libstdc++.so.6()(64bit) is needed by suphp-0.7.1-3.3.x86_64
    libstdc++.so.6(CXXABI_1.3)(64bit) is needed by suphp-0.7.1-3.3.x86_64
    libstdc++.so.6(CXXABI_1.3.1)(64bit) is needed by suphp-0.7.1-3.3.x86_64
    libstdc++.so.6(GLIBCXX_3.4)(64bit) is needed by suphp-0.7.1-3.3.x86_64
    libstdc++.so.6(GLIBCXX_3.4.11)(64bit) is needed by suphp-0.7.1-3.3.x86_64
    libstdc++.so.6(GLIBCXX_3.4.9)(64bit) is needed by suphp-0.7.1-3.3.x86_64

    At uname -a returns
    Linux ins03 2.6.34.7-0.7-desktop #1 SMP PREEMPT 2010-12-13 11:13:53 +0100 i686 i686 i386 GNU/Linux

    What's the problem?

    Thanks,

    Alexa
     
  7. oprea.alex

    oprea.alex New Member

    Hello,

    Is that ok to install suphp via yast?

    Thanks for help,
    Alexa
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Yes, you can do that.
     

Share This Page