sugar crm PHP error on suse 10

Discussion in 'Installation/Configuration' started by nox171, Apr 24, 2007.

  1. nox171

    nox171 New Member

    Hi all,
    I'm now trying to do a new installation of sugar crm and as aspected the sindrome of blank shows up again!

    tailing the error.log I have these messages:

    Code:
    [client my.IP.address] PHP Fatal error:  %v%v() [<a href='function.require'>function.require</a>]: Failed opening required 'include/utils/external_cache.php' (include_path='/usr/share/php5') in /var/www/web30/web/include/utils.php on line 32
    [client my.IP.address] PHP Warning:  %v%v() [<a href='function.%v'>function.%v</a>]: failed to open stream: No such file or directory in /var/www/web30/web/include/utils.php on line 32
    [client my.IP.address] PHP Fatal error:  %v%v() [<a href='function.require'>function.require</a>]: Failed opening required 'include/utils/external_cache.php' (include_path='/usr/share/php5') in /var/www/web30/web/include/utils.php on line 32
    
    I have already chown the web folder for apache:
    chown -R wwwrun:root /var/www/web30/web
    and also i've changed the permission on the folders as descripted in the installtion instruction.

    utils.php Line 32 is this:

    Code:
    require_once('include/utils/external_cache.php');
    
    The external_cache.php is on the server.

    What's going on here?
    Thx!!
     
  2. nox171

    nox171 New Member

    ...and these are my Apache Directives:
    Code:
    php_admin_flag magic_quotes_gpc on
    php_admin_flag zlib.output_compression on
    php_value upload_max_filesize 40M
    php_value max_execution_time 60
    php_value memory_limit 64M
    
    Now when I try to open the website I have these characters in firefox:
    Code:
    ‹���������ÿÿ���������
    
    and using IE I have a download error popup :eek:
     
  3. falko

    falko Super Moderator ISPConfig Developer

    What's the value of include_path in your php.ini?
     
  4. nox171

    nox171 New Member

    Hi falko and thanks for the replay.

    this is the value:
    Code:
    include_path = "/usr/share/php5"
    
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Please change the include path to:

    include_path = ".:/usr/share/php5"

    Otherwise PHP will not allow includes with a relative path.
     
  6. nox171

    nox171 New Member

    I did it but there where still strange simbols on the page, so I removed
    Code:
    php_admin_flag zlib.output_compression on
    
    following this thread and finally the installation page came up!

    Now I'm going through the installtion process but I'm not about the success.... I'll let you know.

    Looking on the SugarCRM platform requirements at the PHP's line there isn't my PHP version: 5.0.4-9
    Is there an easy way to install maybe PHP 5.0.5 with ISPconfig?

    Thansk!
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    This PHP version has nothing to do with ISPConfig, it is the PHP version of your linux distribution. Just install the latest PHP packages for your linux distribution, if there are newer packages then 5.0.4-9 depends on your linux dist. version.
     
  8. nox171

    nox171 New Member

    I've completed the installation without any problems.
    That's strange because there is a checking step and under the heading zlib.output_compression there was a green OK. :confused:
    I'd have expected an error but it was fine! For me that's great!

    Let's see if sugar works fine.

    Ta

    /nox
     
    Last edited: Apr 26, 2007
  9. wayandrs

    wayandrs New Member

    Murgh. :confused:

    I installed the current version (5.0.0) on my Linux server today (current versionsn of php, MySQL), and had a few permissions issues on the install - in the end all went ok, managed to log in once, clicked save to change a theme layout, and that's all she wrote.

    Well that and...

    Warning: require_once(include/utils/external_cache.php): failed to open stream: No such file or directory in /hsphere/local/home/wayandrs/crm.dreamindigo.com/include/utils.php on line 45 Fatal error: require_once(): Failed opening required 'include/utils/external_cache.php' (include_path='/hsphere/local/home/wayandrs/crm.dreamindigo.com/include/..:.:/hsphere/shared/apache/libexec/php5ext/php/') in /hsphere/local/home/wayandrs/crm.dreamindigo.com/include/utils.php on line 45

    What's up, Chuck? I'm not well versed in either php or server stuff, but it looks like a virtual path issue to me. Tried with a .htaccess file for the folder, but didn't manage to fix it.
     
  10. falko

    falko Super Moderator ISPConfig Developer

    What's the value of include_path in your php.ini?
     
  11. wayandrs

    wayandrs New Member

    I have no clue. I'm on a shared server, I manage to poke my way through some php stuff (just enough to be dangerous).

    This is the first open source app so far that I couldn't get up and running. How do I find the php.ini? I don't have access to the server root.
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Then you can't access it. :(
    You can try to create an .htaccess file within your document root with the following line in it:
    Code:
    php_value include_path ".:/usr/share/php"
     

Share This Page