Suexec Not Working

Discussion in 'Installation/Configuration' started by helfrez, Oct 13, 2006.

  1. helfrez

    helfrez New Member

    Am I missing something...
    --Enabled suexec in the ispconfig gui
    --Verified that it was adding the appropriate suexecusergroups to the directives for the vhosts

    --Verified the module was loading successfully
    [Thu Oct 12 22:16:30 2006] [notice] caught SIGTERM, shutting down
    [Thu Oct 12 22:16:32 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec2)
    [Thu Oct 12 22:16:33 2006] [notice] Apache/2.0.54 (Debian GNU/Linux) PHP/4.4.4-0.dotdeb.1 mod_ssl/2.0.54 OpenSSL/0.9.7e configured -- resuming normal operations

    Using Perfect Setup on debian sarge...everything works but I really need to egt suexec working to help manage permissions with these php systems who are only workign with www-data ownership and 777 perms in some cases.

    Is there something I could be missing in a setup somewhere. Other than this point everything else has been workign properly for a few months. I had been managing the perms manually but this has becoem to cumbersome to handle.

    If not suexec, are there another other recommended methods of managing php execution by users on the Sarge perfect setup. Any direction or help would be greatly appreaciated. Let me know what details anyone that can help needs to assist
     
  2. till

    till Super Moderator

    Did you install PHP as CGI? SuEXEC does not affect systems that use mod_php. You should consider installing SuPHP instead.
     

Share This Page