SuEXEC + Fast-CGI = upload error 500

Discussion in 'Tips/Tricks/Mods' started by kevin186, Dec 4, 2010.

  1. kevin186

    kevin186 New Member

    I just finished a new installation of fedora 14 with ispconfig 3 following the perfect server tutorial and I ran into a problem. When I had my websites set to suexec + fast-cgi, I would get error 500 when uploading any files. This happened to my wordpress and slideshowpro director installations. I could not figure it out at first and decided to completely reinstall fedora 14, which still produced the same error and generated the following log:
    [Sat Dec 04 00:39:11 2010] [warn] [client] mod_fcgid: HTTP request length 132532 (so far) exceeds MaxRequestLen (131072), referer:
    The solution was to add the following code to apache directives in the options tab for the website:
    <IfModule mod_fcgid.c>
    MaxRequestLen 15728640
    I don't know the cause of this error because my jpeg was not large at all, maybe 500kb. I was able to upload using any other php option for the websites, such as mod-php, cgi, suphp. I found the tip at the following website:
  2. Ovidiu

    Ovidiu Active Member

    or globally for all sites in this file:


Share This Page