sudo rpmbuild -ta courier-authlib-0.62.4.tar.bz2

Discussion in 'Installation/Configuration' started by The-Ghost, Apr 29, 2010.

  1. The-Ghost

    The-Ghost New Member

    When I try to build courier-authlib, I've some errors.

    configure: creating cache config.cache
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... configure: error: newly created file is older than distributed files!
    Check your system clock
    error: Bad exit status from /var/tmp/rpm-tmp.31416 (%prep)


    RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.31416 (%prep)


    Installing on centos 5.4
     
  2. charlesrg

    charlesrg New Member

    Did you check your clock as the error messages says:
    "error: newly created file is older than distributed files!
    Check your system clock"
     
  3. The-Ghost

    The-Ghost New Member

    That was a problem, but in a next stage, to installe amasd I have a new problem

    amavisd-new-2.2.1-1.0.rh9.rf.i386 from rpmforge has depsolving problems
    --> Missing Dependency: perl(Net::Server) >= 0.86 is needed by package amavisd-new-2.2.1-1.0.rh9.rf.i386 (rpmforge)
    perl-DBD-mysql-4.011-1.rh9.rf.i386 from rpmforge has depsolving problems
    --> Missing Dependency: libmysqlclient.so.10 is needed by package perl-DBD-mysql-4.011-1.rh9.rf.i386 (rpmforge)
    amavisd-new-2.2.1-1.0.rh9.rf.i386 from rpmforge has depsolving problems
    --> Missing Dependency: lha is needed by package amavisd-new-2.2.1-1.0.rh9.rf.i386 (rpmforge)
    amavisd-new-2.2.1-1.0.rh9.rf.i386 from rpmforge has depsolving problems
    --> Missing Dependency: perl(Net::Server) >= 0.83 is needed by package amavisd-new-2.2.1-1.0.rh9.rf.i386 (rpmforge)
    perl-BerkeleyDB-0.36-1.rh9.rf.i386 from rpmforge has depsolving problems
    --> Missing Dependency: libdb-4.0.so is needed by package perl-BerkeleyDB-0.36-1.rh9.rf.i386 (rpmforge)
    Error: Missing Dependency: perl(Net::Server) >= 0.83 is needed by package amavisd-new-2.2.1-1.0.rh9.rf.i386 (rpmforge)
    Error: Missing Dependency: libmysqlclient.so.10 is needed by package perl-DBD-mysql-4.011-1.rh9.rf.i386 (rpmforge)
    Error: Missing Dependency: libdb-4.0.so is needed by package perl-BerkeleyDB-0.36-1.rh9.rf.i386 (rpmforge)
    Error: Missing Dependency: perl(Net::Server) >= 0.86 is needed by package amavisd-new-2.2.1-1.0.rh9.rf.i386 (rpmforge)
    Error: Missing Dependency: lha is needed by package amavisd-new-2.2.1-1.0.rh9.rf.i386 (rpmforge)
    You could try using --skip-broken to work around the problem
    You could try running: package-cleanup --problems
    package-cleanup --dupes
    rpm -Va --nofiles --nodigest
    The program package-cleanup is found in the yum-utils package.
    [[email protected] share]# chkconfig --levels 235 amavisd on
    error reading information on service amavisd: No such file or directory


    Regards
     
  4. charlesrg

    charlesrg New Member

    Did you read the error:
    Error: Missing Dependency: perl(Net::Server) >= 0.83 is needed by package amavisd-new-2.2.1-1.0.rh9.rf.i386 (rpmforge)
    Error: Missing Dependency: libmysqlclient.so.10 is needed by package perl-DBD-mysql-4.011-1.rh9.rf.i386 (rpmforge)
    Error: Missing Dependency: libdb-4.0.so is needed by package perl-BerkeleyDB-0.36-1.rh9.rf.i386 (rpmforge)
    Error: Missing Dependency: perl(Net::Server) >= 0.86 is needed by package amavisd-new-2.2.1-1.0.rh9.rf.i386 (rpmforge)
    Error: Missing Dependency: lha is needed by package amavisd-new-2.2.1-1.0.rh9.rf.i386 (rpmforge)

    You must install the dependencies before building amavis, you should follow the PERFECT SETUP correctly.
     
  5. The-Ghost

    The-Ghost New Member

    I followed the set up, til stage 15, there I got those error's.

    I do follow the commands and only chance the I386 stuff

    Regards
     
  6. charlesrg

    charlesrg New Member

    You may try to install the RPM's required.
    Try:
    yum search lha

    Did you added RPMFORGE into yum repositories ?

    If it does not work then I must say, ISPCONFIG3 is all broken.

    I'm thinking about going to Ispconfig 2 or switching to virtualmin, isp-control, GPL Host DTC or syscp.
    I still have not decided which one exactly.

    Ispconfig 3 comes with promises but it has so many bugs and I really didn't see anything that would make it a must when compared to 2.X

    I would have to research what panel is more stable. I see Ispconfig runs on many more platforms compared to others, but running on all linux distro's is not really a must, installing any distro or switching distros is easy specially when it requires a fresh install.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    @charlesrg:

    ISPConfig 3 is very stable controlpaneland it does not has alot of bugs. Otherwise it would not be the most used open source hosting control panel with several 10 000 of servers. The bugs that are there are listed in the bugtracker and that are not many as especially no severe bugs.

    The recommneded Linux distribution for ISPConfig is Debian Linux. You find this recommendation all over the forum and in the FAQ. If you choose another Linux distribution, it will work on that fine as well but the setup will be more complicated.

    If some software packages are not available for a specific Linux distribution, the thats not ispconfigs fault. The compilation is described in the perfect setup guides, but thats not nescessarily a task for Linux beginners. So better use Debian and you wont get any problems.

    A lot of more features, you seem to have not explored ispconfig 3's capabilities yet. For example multiserver support to manage complete server farms, extended monitoring, virtual mailusers etc.
     
  8. The-Ghost

    The-Ghost New Member

    I started over to setup CentOs 5.4 and now everything works fine.
    The first try was with a netinstall, the second with the normal cd set.

    Thanx Anyway, I stay using ISP Config

    Regrards,
     

Share This Page