Suddenly can't receive email - please help

Discussion in 'General' started by miguelpinheiro, Dec 11, 2008.

  1. miguelpinheiro

    miguelpinheiro New Member

    Hi there!

    I'm running ISPConfig 2.2.28 on Ubuntu 8.04 32 bit.

    A few days ago I stoped from receiving any email from the domain I have with Ispconfig.
    However I'm able to send email from any account.

    This is the var/log/mail.log (last lines):

    Code:
    Dec 11 23:05:35 ks32171 postfix/anvil[30132]: statistics: max connection rate 1/60s for (smtp:206.190.38.62) at Dec 11 23:02:14
    Dec 11 23:05:35 ks32171 postfix/anvil[30132]: statistics: max connection count 1 for (smtp:206.190.38.62) at Dec 11 23:02:14
    Dec 11 23:05:35 ks32171 postfix/anvil[30132]: statistics: max cache size 1 at Dec 11 23:02:14
    Dec 11 23:05:37 ks32171 imapd: Connection, ip=[::ffff:127.0.0.1]
    Dec 11 23:05:37 ks32171 imapd: LOGIN, user=web1_miguel, ip=[::ffff:127.0.0.1], port=[37383], protocol=IMAP
    Dec 11 23:05:37 ks32171 imapd: LOGOUT, user=web1_miguel, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=74, sent=684, time=0
    Dec 11 23:05:54 ks32171 postfix/smtpd[31503]: connect from web50307.mail.re2.yahoo.com[206.190.38.61]
    Dec 11 23:05:54 ks32171 postfix/smtpd[31503]: 7E92068C09F: client=web50307.mail.re2.yahoo.com[206.190.38.61]
    Dec 11 23:05:54 ks32171 postfix/cleanup[31507]: 7E92068C09F: message-id=<[email protected]>
    Dec 11 23:05:54 ks32171 postfix/qmgr[27918]: 7E92068C09F: from=<[email protected]>, size=1295, nrcpt=1 (queue active)
    Dec 11 23:05:54 ks32171 postfix/local[31508]: 7E92068C09F: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=0.5, delays=0.42/0.01/0/0.07, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Dec 11 23:05:54 ks32171 postfix/qmgr[27918]: 7E92068C09F: removed
    Dec 11 23:05:54 ks32171 postfix/smtpd[31503]: disconnect from web50307.mail.re2.yahoo.com[206.190.38.61]
    Dec 11 23:06:37 ks32171 imapd: Connection, ip=[::ffff:127.0.0.1]
    Dec 11 23:06:37 ks32171 imapd: LOGIN, user=web1_miguel, ip=[::ffff:127.0.0.1], port=[42959], protocol=IMAP
    Dec 11 23:06:37 ks32171 imapd: LOGOUT, user=web1_miguel, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=46, sent=432, time=0
    Dec 11 23:06:47 ks32171 imapd: Connection, ip=[::ffff:127.0.0.1]
    Dec 11 23:06:47 ks32171 imapd: LOGIN, user=web1_miguel, ip=[::ffff:127.0.0.1], port=[42960], protocol=IMAP
    Dec 11 23:06:47 ks32171 imapd: LOGOUT, user=web1_miguel, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=71, sent=465, time=0
    Dec 11 23:06:47 ks32171 imapd: Connection, ip=[::ffff:127.0.0.1]
    Dec 11 23:06:47 ks32171 imapd: LOGIN, user=web1_miguel, ip=[::ffff:127.0.0.1], port=[42961], protocol=IMAP
    Dec 11 23:06:47 ks32171 imapd: LOGOUT, user=web1_miguel, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=71, sent=465, time=0
    Dec 11 23:06:48 ks32171 imapd: Connection, ip=[::ffff:127.0.0.1]
    Dec 11 23:06:48 ks32171 imapd: LOGIN, user=web1_miguel, ip=[::ffff:127.0.0.1], port=[42962], protocol=IMAP
    Dec 11 23:06:48 ks32171 imapd: LOGOUT, user=web1_miguel, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=46, sent=432, time=0
    Dec 11 23:07:37 ks32171 imapd: Connection, ip=[::ffff:127.0.0.1]
    Dec 11 23:07:37 ks32171 imapd: LOGIN, user=web1_miguel, ip=[::ffff:127.0.0.1], port=[42963], protocol=IMAP
    Dec 11 23:07:37 ks32171 imapd: LOGOUT, user=web1_miguel, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=46, sent=432, time=0
    Dec 11 23:08:37 ks32171 imapd: Connection, ip=[::ffff:127.0.0.1]
    Dec 11 23:08:37 ks32171 imapd: LOGIN, user=web1_miguel, ip=[::ffff:127.0.0.1], port=[42964], protocol=IMAP
    Dec 11 23:08:37 ks32171 imapd: LOGOUT, user=web1_miguel, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=46, sent=432, time=0
    Dec 11 23:09:14 ks32171 postfix/anvil[31505]: statistics: max connection rate 1/60s for (smtp:206.190.38.61) at Dec 11 23:05:54
    Dec 11 23:09:14 ks32171 postfix/anvil[31505]: statistics: max connection count 1 for (smtp:206.190.38.61) at Dec 11 23:05:54
    Dec 11 23:09:14 ks32171 postfix/anvil[31505]: statistics: max cache size 1 at Dec 11 23:05:54
    Dec 11 23:09:37 ks32171 imapd: Connection, ip=[::ffff:127.0.0.1]
    Dec 11 23:09:37 ks32171 imapd: LOGIN, user=web1_miguel, ip=[::ffff:127.0.0.1], port=[42965], protocol=IMAP
    Dec 11 23:09:37 ks32171 imapd: LOGOUT, user=web1_miguel, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=46, sent=432, time=0
    Dec 11 23:10:25 ks32171 imapd: Connection, ip=[::ffff:127.0.0.1]
    Dec 11 23:10:25 ks32171 imapd: LOGIN, user=web1_miguel, ip=[::ffff:127.0.0.1], port=[42967], protocol=IMAP
    Dec 11 23:10:25 ks32171 imapd: LOGOUT, user=web1_miguel, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=71, sent=465, time=0
    Dec 11 23:10:28 ks32171 imapd: Connection, ip=[::ffff:127.0.0.1]
    Dec 11 23:10:28 ks32171 imapd: LOGIN, user=web1_miguel, ip=[::ffff:127.0.0.1], port=[42968], protocol=IMAP
    Dec 11 23:10:28 ks32171 imapd: LOGOUT, user=web1_miguel, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=76, sent=465, time=0
    Dec 11 23:10:31 ks32171 imapd: Connection, ip=[::ffff:127.0.0.1]
    Dec 11 23:10:31 ks32171 imapd: LOGIN, user=web1_miguel, ip=[::ffff:127.0.0.1], port=[42969], protocol=IMAP
    Dec 11 23:10:31 ks32171 imapd: LOGOUT, user=web1_miguel, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=71, sent=465, time=0
    Dec 11 23:10:37 ks32171 imapd: Connection, ip=[::ffff:127.0.0.1]
    Dec 11 23:10:37 ks32171 imapd: LOGIN, user=web1_miguel, ip=[::ffff:127.0.0.1], port=[42970], protocol=IMAP
    Dec 11 23:10:37 ks32171 imapd: LOGOUT, user=web1_miguel, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=72, sent=684, time=0
    Dec 11 23:10:56 ks32171 pop3d: Connection, ip=[::ffff:209.85.128.190]
    Dec 11 23:10:56 ks32171 pop3d: Disconnected, ip=[::ffff:209.85.128.190]
    Dec 11 23:10:56 ks32171 pop3d: Connection, ip=[::ffff:209.85.128.190]
    Dec 11 23:10:56 ks32171 pop3d: LOGIN, user=web1_miguel, ip=[::ffff:209.85.128.190], port=[15906]
    Dec 11 23:10:56 ks32171 pop3d: LOGOUT, user=web1_miguel, ip=[::ffff:209.85.128.190], port=[15906], top=0, retr=0, rcvd=18, sent=96, time=0
    Can anyone please help me on solving this issue?

    Thanks in advance guys.
    Regards.

    Miguel


    Note: I also noticed that the .procmailrc permissions were 0644 wich caused procmail to complain (suspicious message in mail.log). I set it to 0640 and now that message is not showing anymore. Anyway I still can't receive any email.
    I also notice that if I make any change regarding procmail config (in IspConfig control panel) the .procmailrc is set to 0644 again.
    Is there any way to maintain the file permissions?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The file permissions that ISPConfig sets are ok, they can not be changed without programming and it is not nescessary to change them.

    The mail delivery works fine according to the mail log. Please check that you enabled maildir under management > server > settings on the mail tab.
     
  3. miguelpinheiro

    miguelpinheiro New Member

    Thanks for answering till.

    The maildir is checked. However, I will uncheck it, wait a couple of minutes and check it back again just in case.

    I will update this thread with the results.

    Apart from mail.log, is there any other way to get info on receiving emails?

    Cheers.
     
  4. miguelpinheiro

    miguelpinheiro New Member

    Till,
    I rechecked - uncheck, wait a couple of minutes and check it again -Maildir option as you told me and still can't receive emails.

    Here is another mail.log extract after the changes:

    Code:
    Dec 13 00:50:58 ks32171 imapd: LOGOUT, user=web1_miguel, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=46, sent=432, time=0
    Dec 13 00:51:52 ks32171 postfix/smtpd[7323]: connect from web50309.mail.re2.yahoo.com[206.190.38.242]
    Dec 13 00:51:52 ks32171 postfix/smtpd[7323]: E879868C0CB: client=web50309.mail.re2.yahoo.com[206.190.38.242]
    Dec 13 00:51:53 ks32171 postfix/cleanup[7326]: E879868C0CB: message-id=<[email protected]>
    Dec 13 00:51:53 ks32171 postfix/qmgr[2797]: E879868C0CB: from=<[email protected]>, size=1301, nrcpt=1 (queue active)
    Dec 13 00:51:53 ks32171 procmail[7440]: Suspicious rcfile "/var/www/web1/.procmailrc"
    Dec 13 00:51:53 ks32171 postfix/local[7327]: E879868C0CB: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=0.43, delays=0.41/0/0/0.02, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Dec 13 00:51:53 ks32171 postfix/qmgr[2797]: E879868C0CB: removed
    Dec 13 00:51:53 ks32171 postfix/smtpd[7323]: disconnect from web50309.mail.re2.yahoo.com[206.190.38.242]
    Dec 13 00:51:58 ks32171 imapd: Connection, ip=[::ffff:127.0.0.1]
    Dec 13 00:51:58 ks32171 imapd: LOGIN, user=web1_miguel, ip=[::ffff:127.0.0.1], port=[50131], protocol=IMAP
    Dec 13 00:51:58 ks32171 imapd: LOGOUT, user=we
    Any other hint?
    Thanks in advance for the support.
     
    Last edited: Dec 22, 2008
  5. falko

    falko Super Moderator ISPConfig Developer

    It seems as if there's something wrong with the permissions. What's the output of
    Code:
    ls -la /var/www/web1/
    ?
     
  6. miguelpinheiro

    miguelpinheiro New Member

    Falko,
    here is the result:

    Code:
    [B]root@ks32171:/home/admin# ls -la /var/www/web1/[/B]
    
    total 172636
    drwxrwxrwx  9 web1_miguel web1         4096 2008-12-13 00:50 .
    drwxr-xr-x  7 root        root         4096 2008-11-19 22:54 ..
    -rwxrwxrwx  1 web1_miguel web1         1178 2008-11-18 02:44 .bash_history
    drwxrwxrwx  2 web1_miguel web1         4096 2008-11-16 21:05 cgi-bin
    -rwxrwxrwx  1 web1_miguel web1         1569 2008-11-19 20:03 configuration.php
    -rw-------  1 web1_miguel web1           24 2008-12-13 00:50 .forward
    drwxrwxrwx  3 web1_miguel web1         4096 2008-11-16 21:05 ftp
    -rw-rw-r--  1 web1_miguel web1          142 2008-12-13 04:00 .htpasswd
    -rw-r--r--  1 www-data    www-data        0 2008-11-25 23:33 joomlapack.log
    drwxrwxrwx  3 web1_miguel web1         4096 2008-12-02 00:30 log
    lrwxrwxrwx  1 root        root           38 2008-12-13 00:50 Maildir -> /var/www/web1/user/web1_miguel/Maildir
    -rwxrwxrwx  1 web1_miguel web1            7 2008-11-18 01:01 .nano_history
    drwxrwxrwx  2 web1_miguel web1         4096 2008-11-18 23:59 phptmp
    -rw-r--r--  1 root        root          461 2008-12-13 00:50 .procmailrc
    -rw-r--r--  1 www-data    www-data 86325617 2008-11-25 23:32 site-www.web.com-20081125-233058.jpa
    -rw-r--r--  1 www-data    www-data 90206107 2008-11-25 23:36 site-www.web.com-20081125-233359.zip
    lrwxrwxrwx  1 root        root           45 2008-12-13 00:50 .spamassassin -> /var/www/web1/user/web1_miguel/.spamassassin/
    drwxrwxrwx  2 web1_miguel web1         4096 2008-11-16 21:05 ssl
    drwxrwxrwx  5 web1_miguel web1         4096 2008-11-19 20:57 user
    lrwxrwxrwx  1 root        root           46 2008-12-13 00:50 .vacation.cache -> /var/www/web1/user/web1_miguel/.vacation.cache
    drwxrwxrwx 22 web1_miguel web1         4096 2008-11-25 23:27 web
    
    Trying to solve one of my others issues (install extension in joomla) I guess I've changed the ownership of some directories/files.
    However I do not remember how they were set originally...
     
    Last edited: Dec 22, 2008
  7. falko

    falko Super Moderator ISPConfig Developer

    Please run
    Code:
    chmod 755 /var/www/web1/
     
  8. miguelpinheiro

    miguelpinheiro New Member

    It is working now!!!

    Thanks alot Falko.
     

Share This Page