Sudden problem creating websites

Discussion in 'Installation/Configuration' started by sheshes, Nov 14, 2011.

  1. sheshes

    sheshes Member

    Ispconfig 3 doesn't automatically create the files needed when I add a new website. Although mailbox creation works fine and files are created, when adding a website /var/www/clientX/ doesn't not have the required user files. Also when trying to make a duplication of other website and changing the permissions it looks like ISPconfig doesn't even create the users as chown clientX:web40 returns invalid user.

    Any help?

    Thanks

    p.s I have tried this before and after the latest ispconfig update
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. sheshes

    sheshes Member

    PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/imagick.ini on line 1 in Unknown on line 0
    PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/imap.ini on line 1 in Unknown on line 0
    PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/mcrypt.ini on line 1 in Unknown on line 0
    PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/mhash.ini on line 1 in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626+lfs/mhash.so' - /usr/lib/php5/20090626+lfs/mhash.so: cannot open shared object file: No such file or directory in Unknown on line 0
    14.11.2011-16:47 - DEBUG - There is already an instance of server.php running. Exiting.
     
  4. sheshes

    sheshes Member

    I have fixed all the warnings by changing the commenting from # to // and commented out the module mhash.so

    Now the output of server.sh is

    15.11.2011-08:39 - DEBUG - There is already an instance of server.php running. Exiting.

    Still I am trying to create new websites but no files are created. The same applies with the sites I have removed, no files are removed. They stay as they are in /var/www/

    Any updates??
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Comment out the server.sh cronjob in the root crontab on the slave by adding a # in front of the line. The root crontab can be edited with the command:

    contab -e

    Then run this command on the slave:

    rm -f /usr/local/ispconfig/server/temp/.ispconfig_lock

    Rerun this command until you get a file not found error and then this command again:

    /usr/local/ispconfig/server/server.sh

    and post the output.
     
  6. sheshes

    sheshes Member

    15.11.2011-12:14 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    15.11.2011-12:14 - DEBUG - Found 349 changes, starting update process.
    PHP Warning: include_once(/usr/local/ispconfig/server/plugins-enabled/awstats_plugin.inc.php): failed to open stream: No such file or directory in /usr/local/ispconfig/server/lib/classes/plugins.inc.php on line 64
    PHP Warning: include_once(): Failed opening '/usr/local/ispconfig/server/plugins-enabled/awstats_plugin.inc.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /usr/local/ispconfig/server/lib/classes/plugins.inc.php on line 64
    PHP Fatal error: Class 'awstats_plugin' not found in /usr/local/ispconfig/server/lib/classes/plugins.inc.php on line 66
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run this command to fix the error:

    rm -f /usr/local/ispconfig/server/plugins-enabled/awstats_plugin.inc.php

    There is no awstats plugin in ispconfig 3. I guess you must have build a custom plugin which is not installed anymore and that plugin has not been disabled before it was removed.
     
  8. sheshes

    sheshes Member

    I have done the above steps and fixed most of the errors. I removed a .vhost that was incorrect as well.

    Now i edited cron to remove the commenting we set previously, switched the server config back to Error instead of Debug, but still I have to run the server.sh for any changes to be created in ISPconfig control panel. What am I forgetting?
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Then it might be that cron is not working, installed or started. Please check that cron is isntalled on your server. Also you should be awarre that it takes a minute until changes get written to disk, so you will have to wait at least one minute before you check if a configuration was changed.
     
  10. sheshes

    sheshes Member

    You are very right sir! all things working fine. Just a quick one. AWstats will still be working or i have to re customise it again?
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Awstats is working fine. There is no plugin required for it
     
  12. sheshes

    sheshes Member

  13. till

    till Super Moderator Staff Member ISPConfig Developer

    The statistics are generated nightly. If you create a new website, then you will have to wait until the next day to view them.
     
  14. sheshes

    sheshes Member

    This I know, but with my other domains that was previously working it still doesn't work
     
  15. sheshes

    sheshes Member

    As you said, waited overnight, but now I get ERROR 500 Internal Server Error! when I put the correct password....

    Can't figure it out
     
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    Take a look into the error.log of the website to find the resaon for your problem.
     
  17. sheshes

    sheshes Member

    [Wed Nov 16 11:03:08 2011] [error] [client 192.168.1.182] (13)Permission denied: Could not open password file: /usr/lib/cgi-bin/.htpasswd_stats


    what are the correct permissions for .htaccess in /stats folder and which the owner? Also what are the correct permissions and owner for .htpasswd_stats.

    I have root:root for both of them and changed it to webX:clientX
     
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    Correct permissions are root:root

    This error is not about the .htpasswd_stats file from ispconfig as the ispconfig file is not in the /usr/lib/cgi-bin/. Seems as if your apache setup still contains parts of the awstats configuration that you used before which interferes now with ispconfig.
     
  19. sheshes

    sheshes Member

    Any idea how to revert everything to the correct ispconfig configuration, because when I did the custom installation of awstats ispconfig didn't support it natively
     
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    I've not written that plugin. You might want to contact the developer of the plugin and ask him on how to revert your setup.
     

Share This Page