Subdomain

Discussion in 'General' started by gillesdevals, Dec 31, 2009.

  1. gillesdevals

    gillesdevals New Member

    I work with ISPConfig 3.0.1.6. Linus Debian

    Until now, to create a subdomain :
    - I created a directory (for example /web/newyear10)
    - I created a subdomain with parameters (Host : newyear10 / Domain : devals.ch / Redirect Type : L / Redirect Path : /newyear10/)
    - I created a record "A" in DNS on domain devals.ch with parameters : (Hostname : newyear10 / IP-Address : 91.121.104.212 / TTL : 86400 / Active : Yes)

    But from few weeks when I create with this procedure and type "newyear10.devals.ch" I have the home page of the /web/ directory and not /web/newyear10/

    Anybody can help me ?


    Thanks in advance.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Make sure that the domain has a dns a-record and that you select this ip in the website settings.
     
  3. gillesdevals

    gillesdevals New Member

    I'm sure, the website has a-record with ip address
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I tested the domain newyear10.devals.ch and there is no A-Record.
     
  5. angel1st

    angel1st New Member

    I am not able to create subdomain. I am using IPSConfig 3.0.1.6 under Ubuntu 9.10. Let me explain what I have done:
    1. I have domain beboran.net
    2. I have created folder demo as subfolder of beboran's \web folder. So I have got \web\demo. Currently demo folder is empty.
    3. I have created subdomain with the following params:
    - Host: demo
    - Domain: beboran.net
    - Redirect type: L
    - Redirect path: /demo/
    - Active: Yes
    4. I have created DNS "A" record for beboran.net with the following params:
    - Hostname: demo
    - IP Address: 213.145.124.18
    - TTL: 86400
    - Active: Yes
    When I type demo.beboran.net into the web browser I have got "Firefox can't find the server at demo.beboran.net.". Any ideas?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The problem is the DNS record and not the website.

    1) You have to wait up to 48 hours until changes in dns will be propagated to all caching dns servers.
    2) Make sure that the dns server where you added the A-Record is the authoritive dns server for this domain.
     
  7. angel1st

    angel1st New Member

    subdomain creation

    Hi Till,
    I can confirm it was the case 1 you described. I just have to wait a while, before subdomain became visible.
    Does it mean, that every time I have created a new subdomain, I have to wait up till 48 hours before it become visible?
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    yes. thats not specific or caused by ispconfig.
     

Share This Page