subdomain with mod_rewrite point to shared ip

Discussion in 'General' started by palkat, Jul 16, 2006.

  1. palkat

    palkat New Member

    Okay here is a differant senario using Wordpress MU. So we got it to work with mod_rewrite for folders but now with subdomains it does not seem to work right.

    We setup Wordpress MU so when a person registers their blog name becomes the subdomain (IE:

    The DNS points any and all sub domains via * wildcard to my ispconfig server just fine. but when the subdomain gets to the ispconfig server they only see the ISPConfig page of:
    Shared IP
    This IP address is shared. For access to the web site which you look for, enter its address instead of its IP.
    For questions or problems please contact the server administrator.
    So i have tried to move the .htaccess file to the root folder for the whole domain and still did not work.

    Any ideas?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The shared IP page is always shown, if there is no website in ISPConfig for this combination of IP + domain. ISPConfig currently does not support wildcard domains, but you may add a vhost configuration with the wildcard domain to your httpd.conf file manually, pointing to the website root of the website that you created in ISPConfig.
  3. palkat

    palkat New Member


    I added " ServerAlias domain.tld *.domain.tld " to my Apache Directives (Optional): under ispconfig and that seemed to allow all the * wild cards!

    As always, thanks for the great support!
  4. Ovidiu

    Ovidiu Active Member

    hi guys,

    same problem over here. I had wpmu running but now I had to move to another server and tried to install it again but no chance.

    I added a codomain of hostname=* and and the result inside my vhosts file is this:

    ServerAlias *

    the I added these DNS records as my server also does DNS for this domain: A
    www A
    mail A
    * A

    this should do the trick but still if I access for example I get a DNS error
  5. Ovidiu

    Ovidiu Active Member


    it seemed to be another problem with the DNS, me not waiting long anough for the changes to take effect. the settings above are ok.


    one last question, today I found I had this in my file:

    which entry is correct the * or the * one?
    Last edited: Jul 27, 2006
  6. falko

    falko Super Moderator ISPConfig Developer

  7. Ovidiu

    Ovidiu Active Member

    thx for the links,

    I found those and a lot more too, I had done some heava googleing and searching on wordpress forums before, just wanted to make sure my DNS records were ok.

    though what about this:

    in a wordpress forum I asked if these were ok:

    and got the angry answer to read the posts, cause this is how it should be:

    but this I cannot modify, its ispconfig that generates these DNS entries, isn't it? whats your opinion about this?
  8. falko

    falko Super Moderator ISPConfig Developer

    Have you tried to put a * in the Hostname field when you create an A record? Don't know if that works because we didn't test with wildcards.

Share This Page