Subdomain not working

Discussion in 'General' started by PieLover, Jun 4, 2020.

  1. PieLover

    PieLover New Member

  2. ahrasis

    ahrasis Well-Known Member

    For hostname -f to show your server FQDN you must set it up in /etc/hosts file properly. Please refer to your distro minimal setup tutorial.

    The perfect server setup won't show your server FQDN page unless it is a web server but it is also only limited to show default index.html or apache2 or nginx html page from /var/www/html/ directory.

    After fixing your hostname / server FQDN, follow these tutorials to secure it LE SSL wildcard certs:

    1. For wildcard LE SSL Certs:
    https://www.howtoforge.com/communit...via-certbot-dns-validation-in-acme-v02.79049/ - Please do read the note in the last post in this thread as well.

    2. For securing ISPConfig
    :
    https://www.howtoforge.com/tutorial...with-a-free-lets-encrypt-ssl-certificate/amp/ - Please use your linux knowledge and experince in following this guide.
     
  3. PieLover

    PieLover New Member

    My hostname works, I have the following in my /etc/hosts file.
    SERVER_IP web.domain.tld web
    127.0.0.1 localhost

    I type:
    $ hostname -f
    web.domain.tld

    Do I need to create a record for web.domain.tld in my DNS zone?

    Can I do this with apache?
    I have 2 questions. Do I need to point my nameserver to Cloudflare?
    If I create the wildcard SSL certificate, what about the SSL certificate with Ispconfig?

    It doesn't say how to issue SSL for Ispconfig login panel. My domain.tld:8080 doesnt have SSL, but my domain does.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    It describes how to add let's encrypt on port 8080 for the iSPConfig control panel.

    Then you disabled SSL at install time. do an ispconfig update and choose to enable SSL for port 8080 during update before you follow the guide to enable let's encrypt.
     

Share This Page