subdomain issue

Discussion in 'Installation/Configuration' started by Dy0nisus, Jan 13, 2007.

  1. Dy0nisus

    Dy0nisus New Member

    Hi again!

    We run one Soldat-Server on the ISPConfig controlled Webserver. As we
    had no Management - tool for the webserver we createt a subdomain for
    the log - files of the soldat server like this

    Code:
    <virtual host>
    servername sub.domain.com
    documentroot /home/user/server/log
    </virutal host>
    with ISPConfig u can setup subdomain only within the web dir of the web, right?

    I tried to setup a sym link ... doesn't work ... I get permission problems, even if the owner of the log folder ist the same user of the web.

    Is there any workaround?
     
  2. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Did you copy/paste or retype the configuration info? This is at least in error
    Code:
    </virutal host>
    And IIRC Apache is also picky at correct usage of capitals for directives.
     
  3. Dy0nisus

    Dy0nisus New Member

    no it was no copy and paste, just a quik typing of what i want to achieve
     
  4. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    You should "open" the above directories of /home/user/server/log in such a way that the Apache user can create the log files. On Debian/Ubuntu that would mean drwxr-xr-x (someting like this) for all the directories in the structure /home/user/server/log and change the owner of the log directory to the id that runs apache (www-data ?).
    If you run suPHP of suexec it get's more complicated. Then you might need to make your log directory world writable, but that's for obvious security reasons not advisable.
     
  5. Dy0nisus

    Dy0nisus New Member

    hm i guess we got a little missunderstanding ...

    the apache should not wirte any logs ... the soldatserver writes logs ...

    and we want an subdomain pointing at /home/user/server/logs to read
    the logs.
     
  6. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Then the path /home/user/server/logs should be open for you webserver user for reading.....
     
  7. Dy0nisus

    Dy0nisus New Member

    anybody can read this dir thats the problem!

    but always: Fehler 403 - Verboten!

    so i guess ist the problem with the sym link

    Code:
    ln -s /home/user/server/log /var/www/web2/web/user/log
     
  8. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Can you check the Apache directives SymLinksIfOwnerMatch and FollowSymLinks?
     
  9. Dy0nisus

    Dy0nisus New Member

    I added

    Code:
    Options +FollowSymLinks
    to the Apache Directives field of the web in ISPConfig
     
  10. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Did this fix your problem?
     
  11. Dy0nisus

    Dy0nisus New Member

    no didn'T fix the problem
     
  12. Dy0nisus

    Dy0nisus New Member

    wait ... now i see the shered ip html page ... ?!

    EDIT:

    hmm ... if i type the path www.server.com/user/log ... error 404
    if i type user.server.com ... shared ip ...

    user.server.com refers to www.server.com/user/log

    EDIT:

    i just was to stupid to typ the right url ... its still the problem 404

    EDIT:

    quote form the logfile:

     
    Last edited: Jan 13, 2007
  13. Dy0nisus

    Dy0nisus New Member

    Ahhh searched at the wrong pleace ...

    in /etc/apache2/apache2.conf

    ISPConfig sets Options

    -Indexes ...

    switched it to + .. now it works
     

Share This Page