Subdomain Issue

Discussion in 'General' started by Erslan, Sep 12, 2012.

  1. Erslan

    Erslan New Member

    Hi, I will really appreciate if someone help me. I add a subdomain
    blog.mysite.tld pointed properly on sub-directory of mysite.tld. But whenever i tried to open it redirects to www.blog.mysite.tld and shows mysite.tld root files.

    I want to point both (www.blog.mysite.tld & blog.mysite.tld) on sub-directory of my mysite.tld

    Thanks
     
  2. pititis

    pititis Member

    Do you need to add a DNS A record for blog. Did you?


    Cheers
     
  3. Erslan

    Erslan New Member

    Yes i do add DNS A record for both blog and www.blog
     
  4. pititis

    pititis Member

    Are you using * for this vhost or the ip address? You should use * for all vhosts or ip addresses, but not both.
     
    Last edited: Sep 12, 2012
  5. Erslan

    Erslan New Member

    Sorry, i don't understand. Please explain.

    Here's a screen shot:
     

    Attached Files:

  6. pititis

    pititis Member

    I can access to your domain and subdomain but not to www.blog. Please choose www. in Auto-Subdomain
     
  7. Erslan

    Erslan New Member

    Thanks i just change this.. any changes for DNS ?? I attach a screenshot of my DNS settings.
     

    Attached Files:

    • dns.jpg
      dns.jpg
      File size:
      40 KB
      Views:
      50
  8. Erslan

    Erslan New Member

  9. pititis

    pititis Member

  10. Erslan

    Erslan New Member

    I did. But it is still showing server page.
     
  11. pititis

    pititis Member

    Select an IP address instead * ( IPv4-Address drop down menu)
     
  12. Erslan

    Erslan New Member

    I tried. but there is only IP address is not available. Only "*" is available
     
  13. pititis

    pititis Member

    Ok,

    Add an ip to the system before.

    System->Server ip addresses.

    After that you will see that ip in the dropdown. Then choose the ip for all your websites instead * (don't mix ip and * for your websites)
     
  14. Erslan

    Erslan New Member

    I have only 1 dedicated IP. There is no ip listed here. Should i manually add IP?
    Kindly tell me why "*" is used ?
     

    Attached Files:

    • ip.jpg
      ip.jpg
      File size:
      31.1 KB
      Views:
      45
  15. Erslan

    Erslan New Member

    I manually add IP address. and select IP address in IPV4 field. now it is showing main site page i.e erslan.me when i try to open www.blog.erslan.me
     
  16. pititis

    pititis Member

    Check your subdomain redirect type and be sure thar you select the L flag.

    However I forgot a very important information, sorry. If you intend to use a cms like joomla or wordpress you must to add the subdomain in the domain tab (because the apache rewrite rules will collide with the rewrite rules from your cms) .This will create a complete new vhost for your blog.

    So, the idea is:

    - Delete the subdomain entry in websites->subdomain
    - Add domain erslan.me (using the domain module, you are done here.)
    - Add subdomain blog.erslan.me (using the domain module)
    - DNS entries (you are already done)
    - Enjoy

    Now you have 2 websites, one for your main site and a second for your blog.
     
  17. Erslan

    Erslan New Member

    Thanks alot. I did. But It is still showing old erslan.me page.
     

Share This Page