Subdomain is not activating on specific domain

Discussion in 'General' started by Sheshman, May 12, 2021.

  1. Sheshman

    Sheshman Member

    I'm trying to define a subdomain to a specific domain but somehow it's not activating, i'm trying to create by following below steps;
    -- Sites->Add new website->>create
    --DNS->edit's zone->Add A record->Host name:nc / IP Address : my wan ip / TTL :3600 ->Save
    When i follow those steps on another domain, subdomain activating in 3-5 minutes and i can ping through or can reach through browser, but it's not activating, i thought maybe i should wait for couple hours and waited but it didn't become reachable.

    Screenshots as attached, What am i missing here?

    Attached Files:

  2. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    1. I would check if my dns server is working correctly and for this I would follow @Taleman tutorial.
    2. If the first is ok, then I would check if in my bind there is any created error file and fix them, if any.
    Sheshman likes this.
  3. Sheshman

    Sheshman Member

    deleted and adding domain solved the problem, before that i've checked dns & bind everything was ok, strange indeed.
  4. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    That somehow shows there could be error and deleting domain deleted it as well.

    May be a change to its settings or running dns resync could fix it as well but that is for you try if things happened again in the future.

    I don't maintain a dns server so I don't really have active experience except when I was maintaining few of them quite sometimes ago.
    Sheshman likes this.
  5. Sheshman

    Sheshman Member

    Now it's gone again, it worked after delete and add domain (website,dns,email,ftp accounts) for 5-10 minutes and it's not reachable (ping,dns lookup). I don't know why but server obsessed with this domain :) Added 4 new domains yesterday and they activated in 5-10 minutes all over the world but server don't want to activate this domain anyway :) I don't even know where else to check, i don't have a dns server pointing my domains with glue record.
  6. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    I don't think you should mix dns server problem with other servers though they may be setup as one ISPConfig single server.

    Check at your domain registrar whether it is pointed on your dns server ip address.

    Otherwise, you could always test the domain using free dns service like CloudFlare.
    Sheshman likes this.
  7. Sheshman

    Sheshman Member

    checked with cloudflare's diagnostic tool, and it's returning error for everything, it's acting like this domain doesn't even exist :) I just realised that in my domain control panel, it shows that i'm behind payment for this domain but pretty sure i've paid for this year, so i believe that is the problem, they probably de-activated my domain due to payment problem, so i'll talk with them and will update the subject if this is the problem.
    ahrasis likes this.

Share This Page