sub-domains with ispconfig on dynamic ip

Discussion in 'General' started by NemesisX, Jul 5, 2008.

  1. NemesisX

    NemesisX New Member

    Hello everyone, this is my first post and i want to say thank you. This site is really helpful and i really learned a lot, but i still consider myself a newbie.

    I have installed CenOS 5.1 following the perfect setup tutorial. I have also bought a domain from namecheap and as i don't have a static ip i have configured ddclient to update the dns record. It is setup to update www and @ to my current ip.

    So my first question, will setting it up to @ cover all the sub-domains for my domain?

    Second question, in ispconfig when i create a new site and set up co-domain as
    host: subname
    domain: mydomain.tld
    i get: The Domain belongs to another client.
    How can i solve that to be able to host sites on sub-domains?

    Sorry if this has already been answered, i couldn't find it anywhere, and it seam quite specific.

    Thanks in advance.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Doyou use a sepoarate router so that your ISPConfig server is in a NAT enviroment?

    Add the subdomains to the same client.
  3. createch

    createch ISPConfig Developer ISPConfig Developer

    I just wonder how can ISPconfig update all the domain records' IPs if you are using dynamic IP..... (anyone gets an idea ?)
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig is not updating them and this is not needed when you run your server in a NAT enviroment.
  5. NemesisX

    NemesisX New Member

    i don't use the separate router. i managed

    to solve it by makeing ddclient update the a record for the host thath is the name i name.mydomain.tdl and it works now.

    i use ddclient on centos to update the namecheap a record for my ip and just use the host names in ddclient as the ones i define for the subdomain in nc control panel

    also, what do i need to do to make email work. i have setup the dyndns update for smtp and pop domain but that also doesn't work, i have tried to send on gmail and i get rout to host not found as a response from gmail and from some other host i get connection timed out, and for it works(prolly coz they are my isp)
    Last edited: Jul 6, 2008
  6. falko

    falko Super Moderator ISPConfig Developer

    What are the exact error messages? Are there any errors in your mail log?
  7. NemesisX

    NemesisX New Member

    this is the log from maillog
    Jul  7 20:32:25 web1 postfix/smtp[6281]: connect to[]: No route to host (port 25)
    Jul  7 20:32:25 web1 postfix/smtp[6280]: connect to[]: No route to host (port 25)
    and is constantly repeated all the time

    Thanks in advance
  8. falko

    falko Super Moderator ISPConfig Developer

    IS the system's internet connection working? Can you ping, for example?
  9. NemesisX

    NemesisX New Member

    yes i can, i download updates and everything all the time

    i can receive mail now but when i send i still get no route to host from servers i'm sending to.
    Last edited: Jul 8, 2008
  10. falko

    falko Super Moderator ISPConfig Developer

    Can you ping and
    What's the output of
    route -nee
  11. NemesisX

    NemesisX New Member

    thanks for all the help, i have fixed the problem.

    i just had to fix the relay info to relay my mail server trough my ISP.

Share This Page