Stupid newb question: which IP, where?

Discussion in 'Installation/Configuration' started by sagewah, Aug 9, 2006.

  1. sagewah

    sagewah New Member


    I've followed the comprehensive and very well done Ubuntu setup guide with no problems. I've installed ISPConfig using what I -think- are the right settings. I've set up my first site... and it's sort of working.

    The situation: I have a newly registered dn. I've pointed it (a record) at the new box's external IP, and I've set up NAT translation on the firewall so anything to that IP goes to the new box. Currently we're relying on external name servers but I hope to host our records internally on this box in the very near future.

    Now that DNS has propogated, I can enter the new name on an external machine and it goes to the main site; i.e. I put in and it goes to the main 'shared ip' page. However, when I put in it gives me a 'server not found error'.

    Now, I may be horribly sleep deprived (which is why I haven't already got this figured; I'm a bit brain damaged at the moment) ut it seems apparent that my DNS configuration is obviously not quite right. Further, I'm not at all sure I've given ISPConfig the right details: I've told it about its internal IP, and it's internal FQDN (we're running on an AD, so that makes the box's fqdn Further, while I've got BIND running happily on the box, we're stuck using external nameservers for the time being and I haven't yet opened up the firewall to allow DNS stuff through.

    I won't start asking about how to set everything up so it all works with a different mail server and so on, I figure it makes more sense to get the basics working first :)

    Thanks in advance for any and all help!
  2. sagewah

    sagewah New Member

    Hmm.. using an external box with an appropriate hosts file entry everything works as it should - which means I need to figure out how to host my own DNS settings so subdomains (like www, ftp, etc) magically work.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    You must select your internal IP address and not your external IP in the settings of your website whne you are in a NAT enviroment behind a router.
  4. sagewah

    sagewah New Member

    Cheers mate :) Another piece of the puzzle sorted!

Share This Page